AnsweredAssumed Answered

Enable Dedicated Graphics Card

Question asked by jleicester231 on Aug 6, 2016
Latest reply on Aug 7, 2016 by jleicester231

Hi,

 

Just picked up a new PC from PC Specialist.

 

Specs are as follows:

Processor (CPU)Intel® Core™i5 Quad Core Processor i5-6400 (2.7GHz) 6MB Cache
MotherboardASUS® H110M-R: Micro-ATX, DDR4, LG1151, USB 3.0, SATA 6GBs
Memory (RAM)16GB HyperX FURY DDR4 2133MHz (2 x 8GB)
Graphics Card8GB AMD RADEON™ RX 480 - HDMI, 3 x DP - DX® 12

 

I currently cannot get maximum settings on older games like Payday 2 or Borderlands 2, as well as on next gen games such as Just Cause 3 or Rainbow 6 Seige.

From benchmarks I was lead to believe running these would be easy. However, I have to run JC3 and R6S in very low settings, and Payday 2 and Borderlands 2 both run only around the medium mark.

I believe the issue is that the machine is only using the integrated graphics card, as when running DxDiag i get the following:

Showing only the integrated card, not the dedicated one.

Both cards do appear in the dev manager.

I did try to automatically update graphics drivers but said they were already updated, and I have tried installing the AMD Raptr software but it didn't seem to do anything.

Does anyone know either of a way to make sure the dedicated card is being used properly, or if there may be something else causing the issue?

Outcomes