AnsweredAssumed Answered

AMD Driver causing BSOD while running Win10 driver verifier - What to do?!

Question asked by frebreeze on Jul 29, 2016
Latest reply on Aug 21, 2016 by itgrunt

Edit1: **Could a moderator mark this as unanswered still? I accidentally clicked the answered button, even though it clearly is not.

 

R9 380 4gb - running 16.3.2 crimson, most recent driver

 

I have been crashing very frequently while running Overwatch (exists out of the program, but not crashing my system) as well as occasional 1-2 a day *BlueSODS usually during game but very rearely even idle on the desktop screen. I ran Win10 verifier in order to investigate what could be causing this, it seems like an AMD driver. The BSODS have been ranging in type such as irql_not_less_or_equal, various memory issue ones, or even a paging file size one I believe.

 

The reason I suspect it is AMD is because of the error message I received when trying to investigate what is causing all these issues (by running verifier to stress my drivers)

 

ERROR: Module load completed but symbols could not be loaded for atikmpag.sys

Probably caused by : atikmpag.sys ( atikmpag+105c )

 

I have posted the full crash dump file in .txt format as an attachment for the debuggers who want to look into it.

 

I have also posted a zipfile containing various info about my software on the computer. I borrowed this program from tenforums.com. Should help with those who want to really dig in and diagnose

 

Various fixes and diagnosis I have tried:

  • Install a fresh copy of windows and all the drivers
  • Make sure all other drivers are updated (including bios)
  • Changed various graphical settings ingame (ranging from lowest to highest, all crashing, as well as various different screen rates)
  • Ran the *more* stable Crimson 15.11.1 beta driver, still crashes during then. So I have reupdated back to most recent one.
  • Set a longer TdrDelay value (now currently at 8)
  • Ran memtest86 overnight to check ram. Passed 6 full tests, no errors.
  • Maybe some other stuff but can't remember, would love to hear what you think

 

Thank you for taking the time to read the post, hope to hear from someone!

 

Edit 1: Another BSOD: During youtube video

     SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (7e)

     Probably caused by : atikmdag.sys ( atikmdag+fe357 )

     Uploaded as (Crash2.txt)

          **I used DDU and reinstalled only the AMD video driver(Crimson 15.11.1) (went to Realtek website for most recent audio driver . Didn't restart, used CMD and typed:

                     'expand.exe atikmdag.sy_ atikmdag.sys'  (found in AMD folder)

                     'expand.exe atikmpag.sy_ atikmpag.sys'  (found in AMD folder)

          **Moved these back into my System32->drivers folder, seemed to be a bit more stable at first, but then returned back to crashing.

Outcomes