5 Replies Latest reply on Mar 6, 2017 3:33 AM by gigaflop

    Can't see the 'enable crossfire' toggle in Crimson 16.7.3 - any ideas?

    onlyjoeking

      Hi folks,

       

      First time builder here so please excuse my ineptitude! But I am at my wits end, and could really do with some advice.

       

      I built a gaming PC towards the end of 2015, and have been happily gaming until now, but have been unable to shake the feeling that I could use a bit more graphical power to fuel my 3440x1440 display. My R390 gets by, but I bought it with an eye on the new cards coming out soon..... as it happened though, the RX480 doesn't really offer a performance improvement, so with Vega potentially a year away I decided I might as well slap in another R390 to tide me over until the next wave arrives.

       

      After a lot of frustration getting set up, I've arrived at a point where the PC recognises the second card, but it isn't being used, and there is no toggle anywhere in the Crimson software to enable crossfire. I'm certain of this - it's not in the Global Settings tab, it's not under Additional Settings accessed through Preferences, it's not under the Video tab, nor is it under the Display tab. I've included screenshots to show what I mean.

       

      The second GPU is recognised by Crimson, but if you move the mouse over the 2nd R390's tab in the System tab, it says it's 'disabled'. Frustratingly, if you click into a game profile, there is a crossfire settings button, set to default, but this doesn't seem to let me enable it. I'm certain the 2nd GPU isn't being used too, as I've played a bit of a game with a crossfire profile, Fallout 4, and as you can see from the attached MSI Afterburner screenshot taken immediately afterwards, the second GPU isn't being used. I also tried the Total War: Warhammer benchmark with crossfire set to default in the Warhammer tab in Crimson, and again with it set to disabled, and there was no difference in framerate. Finally as you can see from the last screenshot, the 2nd GPU is recognised in Device Manager.

       

      In order to fit the GPU in I had to take out my mechanical hard drive, which meant that I had to completely reinstall Windows 10 (apparently if you install it with two hard drives on it installs a tiny but really important bit on the second hard drive, without telling you). So this means everything has been installed from scratch, with only the latest drivers for everything (Crimson 16.7.3). I've tried uninstalling and reinstalling to get it working, and apart from rendering my PC unable to boot a couple of times, no joy. I've even flashed the BIOS to a newer version. It's so frustrating! The PC was working completely fine for the last 6 months so I don't think any of the components are the problem.

       

      So I now really have no idea what to do, and have been messing around with it for days now.... does anyone have any idea what the problem might be?

       

      My full system specs:

       

      • i5-6600K (now clocked to the standard 3.5ghz after having to reinstall windows)
      • Corsair H110i GT 113.0 Liquid CPU Cooler
      • Asus Maximus VIII Ranger ATX LGA1151 Motherboard
      • Corsair Vengance LPX 16GB (2x8GB) DDR4-3000 RAM
      • Samsung 850 Evo 250gb 2.5" SSD (with operating system installed)
      • Samsung 850 Evo 500gb 2.5" SSD
      • Sapphire R9 R390 Nitro OC Edition (w.backplate & small overclock)
      • Sapphire R9 R390 Nitro OC Edition (w.backplate & small overclock)
      • Cooler Master VSM 750W 80+ Gold Certified Semi-Moduar ATX PSU (it's pushing it a bit with a 750W PSU, I know, but surely that's not the reason for the crossfire toggle not appearing in Crimson?)
      • Windows 10
      • Acer Predator XR341CK Freesync Monitor

       

      ................Thanks in advance!!!! And sorry for the essay.... if someone could please just point out that I've missed something really obvious and it's an easy fix, that would be great. Cheers!

       

      Joe