2 Replies Latest reply on Jul 25, 2016 11:25 AM by cyclonica

    Freesync not working with RX 480 and AOC G2770PQU - kind of fixed

    cyclonica

      Hi,

       

      I upgraded my R9 380 to RX 480 a few days ago, and one of the first things I did was to check if my FreeSync was working, using the FreeSync application and just general testing in games. It wasn't.

       

      I tried 16.7.1 and 16.7.2 drivers but nada. I resigned myself to once again using VSync until I had more time to troubleshoot.

       

      This morning I was playing around in the Catalyst display panel when I thought, "Hey, I'll try turning Virtual Super Resolution ON". Sure enough, I boot up FreeSync ap and voila - no screen tearing! I double checked with the Test Pattern as well, and 100% no tearing.

       

      However, when I tested it in a few games I still get some tearing, depending on the game. No tearing in WoW, no tearing in Overwatch, but I do get tearing in Doom (Vulkan API).

       

      Has anyone else experienced something similar?

       

      P.S. The AOC G2770PQU monitor is set to 120Hz (I get the screen flickering rx 480 bug on 144Hz) and does have the beta AOC drivers that increase the FreeSync range up to 144Hz.

       

      EDIT - I have managed to get FreeSync working in Doom as well. It appears that my monitor refresh rate in Windows got reset to 60Hz when enabling VSR above. Changing it back to 120Hz fixed the issue.

       

      Cheers,

      Cy