13 Replies Latest reply on Jul 25, 2016 6:13 AM by amdmatt

    R9 280X crossfire System Crash

    cashby

      I have tried to use the latest AMD graphic drivers 16.7.1 on my system but anytime i try and play a game my system would just black screen and restart. This happens in GTAV i can get to the menu but as soon as i start game it crashes. I tried Lego Marvel Super Heroes and i would get a blue screen of death after the game starts up. I tried THe Division and i could actually play a mission but soon after again black screen and restart to the PC. This was after about 10 minutes of play.

      I have to use the older 16.2.1 driver and all those games work perfectly.

       

      I originally had that driver and when i used to upgrade from this one i would get a system Hang and also i would have to re-install windows 10.

       

      Are these drivers not supporting the older R9280X cards?

       

      im running:

      Windows 10 64

      Asus R9280X DC2TOP Crossfire

      AMD FX 8150 4.1GHZ

      16GB ram

      AsRock 990FX Professional Motherboard.

        • Re: R9 280X crossfire System Crash
          amdmatt

          The 280X is definitely supported in our latest drivers. Please try the steps below to clean up your system and the existing AMD drivers, see if it resolves the issue.

           

          1. Run the Windows self check tool to check scan and automatically repair any corrupt files found in Windows. There is a guide on how to do it here.  What you need to do is run an elevated command prompt (elevated means run it as administrator) and type SFC /SCANNOW. This will generate a statement indicating if errors were found the Operating system and if they were fixable.

           

          2. Make sure you have installed Microsfot NetFramework and Visual C++ 2013. These should be installed already, but they can become damaged, need repairing or reinstalling.

           

          3. Update Windows. Install all available critical, recommended and optional updates. Often Netframework and Visual C are included in the recommended or optional updates Windows provides. Windows should always be fully up to date before installing our drivers!

           

          4. Use DDU to sweep the system of AMD drivers.

           

          5. Temporarily disable your antivirus and install the latest Crimson 16.7.2 drivers once the above is completed and test to see if the issue is resolved.

            • Re: R9 280X crossfire System Crash
              srs13rastus

              Similar Build to myself.

               

              AMD 9590 + 16GB = 2 R9 290X 8GB from Sapphire.

               

              I've been having other problems to these but the fix I found may still help you out.

               

              Crossfire Option Not Showing Up Even Though Everything Is Put In Correctly.

                Check crimson global settings to check if Crossfire is visible if it is you might want to try the same update the drivers to ver 16.3.2 and then also 16.7.2 hotfix but both times remove the 2nd GPU during the fresh install. Then try the regedit I mentioned in my 2nd post. That may stop the freezes and BSOD's you're getting as it lengthens the time windows 10 allows a driver to recover.

               

              WIN 7 had an MS fixit to do this for you but Win 10 you have to do it yourself...

               

              GL and hope it helps you too.

              • Re: R9 280X crossfire System Crash
                cashby

                thanks AMD Matt = this allowed me to install the latest drivers without that black screen hang.

                However i tried to start up GTAV and i cant even get to the first Rockstar Logo without the system black screening and then restarting. so it allowed me to install the driver but then my games dont work. kinda pointless.

                  • Re: R9 280X crossfire System Crash
                    amdmatt

                    Have you tried other games? Have you changed any settings within Radeon Settings?

                     

                    Try pressing Alt + Enter when GTA V starts to switch to Windowed mode.

                     

                    Check Windows Display Properties to ensure that the correct refresh rate has been set for your display.

                      • Re: R9 280X crossfire System Crash
                        cashby

                        Ok so i tried Lego marvel SuperHeroes again and that gives me the blue screen of Death. I tried The Division and i had the same issue as GTAV. I tried it again straight after the reboot and got the warning message from the game and then it rebooted.

                         

                        So i disabled crossfire mode in radeon settings and tried GTAV - the game loaded up fine no issues at all. so the driver is impacting the cross fire mode. I might have to follow SRS13rastus way of getting the drivers to work - it seems that the new driver is only updating one card for some reason - if thats even possible

                          • Re: R9 280X crossfire System Crash
                            cashby

                            now im getting the same errors after i have gone back to 16.2.1. ffs

                              • Re: R9 280X crossfire System Crash
                                amdmatt

                                Can you try Windows System Restore to before you had any crashes?

                                  • Re: R9 280X crossfire System Crash
                                    cashby

                                    after a lot of stuffing around i was almost ready to do another clean install of windows 10. i then tried a DDU by wagner or whatever his name is. this cleared it out and i then let windows 10 install the AMD driver. I took note previously though that AMD radeon settings was for some reason setting my 2 cards on different speeds. when they are exactly the same card. This was setting the memory 2000MHZ - the 2nd card was showing as 4000MHZ. i adjusted it and then it changed back to 2000MHZ. again i had the same issues on 16.7.3 - game load and then dies. i then realised that these graphic cards are only 1600MHZ and then it decided to change one to 1600MHZ but not the 2nd one. i again reset the global settings and they then lined up. I then played the game and Voila! it works!! so after all this its the AMD settings trying to overclock my cards which was causing them to become unstable. hopefully this hasnt caused any long term issues...

                                     

                                    So from now on - if i install a new driver i will be checking those settings to make sure they are both set at the correct rates.

                                      • Re: R9 280X crossfire System Crash
                                        amdmatt

                                        Radeon Settings should not alter clock speed under any circumstance unless you changed the speeds yourself, or you used a third party overclocking tool. Nonetheless, glad it's all sorted now.

                                          • Re: R9 280X crossfire System Crash
                                            cashby

                                            Yeah ive never messed with the overclocking of the graphic cards. im not that technically advanced to even try. The only thing that may have caused it in to an overclock is the ASUS GPU Tweak - i only use that though for a profile so the fans speeds start before the cards get too hot and start glitching out.

                                             

                                            I know i didnt mess with it in the AMD settings as i had to agree before i even could look in to them..

                                             

                                            Card 1

                                             

                                            Card 1.png

                                            Card 2

                                             

                                            card 2.png

                                             

                                            ** also note on card 2  - look at the memory Clock. The Max is 2000MHZ but it was showing as 3190MHZ.

                                             

                                             

                                             

                                             

                                            What it should have been for both cards

                                             

                                            how it should be.png

                                             

                                            Just glad i figured out what it was. stumbled on it as i have never been in to those settings to change anything before.

                                             

                                            Can you set up fan profiles in this program rather than using ASUS GPU Tweak 2?