3 Replies Latest reply on Oct 15, 2016 1:37 PM by j38uzzs

    Can´t install driver RX 480

    karachokid

      Hey,

       

      my Problem is, that i can´t install the drivers for my rx 480.

       

      I build my PC a few days ago, so there are no old drivers.

      As i plugged in my RX 480, everything is fine, until i install the drivers. At roundabout 50% i got a black screen an my pc makes a little "swoosh" sound. After that, all i can do is turn it off. After a restart, i see the windows logo and suddenly i get a black screen with this "swoosh" sound. I sounds like a fan turns suddenly off ( but as i see all fans are spinning ).

       

      I use Win 10, updated my BIOS, installed all chipset drivers and my Graphics Adapter in Windows is shown as "microsoft basic display adapter". I switched my Primary Graphics in BIOS to PCI-E but that didn't help. Also I tried to install the drivers manually, and i could swear under win 8.1 there was a short moment, when my PC recognized the RX 480 before there was a black screen.

       

      So has anyone a solution?

       

      Sytem:

       

      Asus z170 pro gaming

      Intel i6700k

      ASUS RX 480

      Crucial Sport 32GB

      Dell 2515h

      Bequiet 500W

        • Re: Can´t install driver RX 480
          amdpete

          That PSU looks a little wimpy to do the job, a 650W would be my recommendation, that could be the cause of your issue.  I have a similar motherboard to you (Asus Z170a Pro gaming Carbon) and same CPU along with Windows 10 X64 and 2x 480 cards, 16GB of RAM but I am using a 1000W PSU.

          • Re: Can´t install driver RX 480
            amdmatt

            Agree with Pete.

             

            Also this could be a faulty GPU. Have you tried installing the 480 into a different PCI-E slot and then installing the drivers?

             

            If you can try the 480 in a different system that might narrow down the problem.

            • Re: Can´t install driver RX 480
              j38uzzs

              Hi all,

               

              I have this exact same issue...

               

              I originally had a Sapphire RX480 Reference, that was suffering from this problem. (Black screen during and after driver install)

              I put it down to the sapphire card being bad and sent it back.

              Today I received a brand new XFX RX480 GTR (decided to upgrade if I had to send it back as I didn't want another Sapphire card)

              And boom, exactly the same issue...

               

              Done everything I can think to try, different versions of driver, minimal driver installation, allowed windows to install the driver itself using Windows update, tried a brand new fresh install of Windows 10 64-Bit on a different hard drive, tried both BIOS settings on the switch, nothing has worked! (Each time cleaning the registry and wiping all graphics drivers in safe mode when it didn't work) I have also flashed the BIOS to the latest version on XFX's website for the 480 to see if this would help, it didn't!

               

              I have a 650 watt power supply, which should be more than enough to power the 150W quoted for the XFX 480.

               

              I'm an experienced system builder and I have never had this much of a problem with a card before, let alone 2 separate cards!

               

              You're not alone Karachokid !

               

              This thread might help you: To people who have instant Black Screen or Freeze on installing ANY AMD driver  

              But as far as I can see, there's no fix that anyone has come across yet...