13 Replies Latest reply on Jul 14, 2016 1:59 AM by atlasminor

    Amd Crimson Driver doesnt work on W10 and Sapphire 7970

    foxslink

      Status: Unresolved

      Computer Type: Desktop PC

      GPU: Sapphire Hd 7970 Dual-x 3gb Gddr5 (factory OC, using single GPU)

      CPU: Intel Ivy bridge i5 3570k

      Motherboard: GIGABYTE GA-Z77X-UD5H LGA1155

      RAM: Kingston Predator 8GB

      PSU: Corsair TX650M 650w 80Plus Bronze

      OS: Windows 10 Pro 64 bits

      GPU Drivers: Radeon crimson 16.6.2 Hotfix (Partially and defectively installed, only INF files through device manager)

      Chipset Drivers: z77 chipset LPC- 1E44 , version 10.1.1.8

      Background Applications before Black Screen: http://imgur.com/T1Qz5wi

       

      Description of Problem:

      After installing Windows 10 Pro on a new Seagate drive, everything was ok for a while, I was downloading drivers and moving around the desktop, but then all of a sudden i got the black screen of death , i did a reboot and i was unable to get past the loading screen of the windows logo, the circle thing got stuck. I rebooted  till i finally made it into safe mode, there I disabled the intel HD driver on device manager and i was able to log into the desktop in the next normal boot, but then another crash, i tried to install the Crimson drivers and right after i clicked the setup the screen freezes and i cant do anything, i can move the mouse but nothing responds so I'm forced to reboot, i tried installing the AMD drivers on safe mode and it said there was an error finding the device controller.

       

      Troubleshooting:

      The last thing i tried was to manually install the Crimson drivers on the device manager, by clicking on the default display driver, then update driver and manually choosing the path to the extracted AMD folder, it installed correctly, switched the resolution to 1080 automatically( monitors native res) but nothing else changed, catalyst center didnt install so i tried opening the setup again to find the same issue reported above, system freeze and reboot, then i have to do the same annoying procedure, going into safe mode, disabling intel HD graphics on device manager , idon't know why it keeps activating on its own ( how can i stop that?), and then rebooting into windows again. I even used DDU again to see if i can install the driver afterwards, but same result, should i switch to an specific older version of crimson, or  catalyst? I'm out of ideas and i have no clue what is causing all this, ive also seen many people on the forum having problems with the new drivers.
      Id appreciate your help guys,  looking forward to your reply