7 Replies Latest reply on Sep 25, 2016 6:27 PM by 4dm

    R9 280x - No displayport output - 144hz?

    4dm

      Hi, I've tried searching for an answer and haven't come up with anything for this. I am hoping it's not a hardware issue...

       

      My R9 280x is not outputting anything over displayport. I have tried multiple cables with multiple monitors, and nothing is detected on the monitor or on Windows 10. HDMI and DVI work fine, it is only the displayport issue. I have uninstalled and reinstalled drivers several times. Unplugged power completely, and cold booted after every fix attempt.

       

      My new monitor has only HDMI 2.0 and Displayport 1.2, so Dual DVI does not seem like a good choice. I play fast-paced games, so need the input delay kept to a minimum. I am hoping to somehow get 144hz working on this, and displayport seems like my best option.

       

      Is there anything software-wise that needs to be enabled? Is there anything I need to do specifically with my system to get it to work? I would really appreciate any help!

       

      ASUS AMD R9 280x Top CU II

      i7 4770

      Asrock Extreme6 Motherboard

      32gb DDR3 Ram

      512gb NVME M.2 PCIEx4

      Windows 10 64 bit

      Catalyst 16.3.2