0 Replies Latest reply on Jul 2, 2016 9:39 AM by ikasugami

    Computer won't auto sleep after upgrade to Win 10

    ikasugami

      So I honestly don't know if this is an AMD thing or a Windows thing, and I'd venture to guess it's a Windows thing, but I'm posting it here anyway because I have not gotten any good responses on the Windows forum and am hoping somebody can help...

       

      I had Windows 7 on my desktop that I upgraded to Windows 10 (64-bit).  After the upgrade was complete, I used the AMD utility to update AMD drivers.

      Now my computer will not automatically go to sleep (it used to work fine with Win 7, and nothing else has changed).

      I went into Device Manager and made sure that any of the items that have a Power Management tab have "Allow this device to wake the computer" unchecked (namely those were the network adapter, keyboard, and mouse).

      I went into my Power Options and made sure the Balanced plan is selected.  I lengthened the amount of time until the display turns off and then the computer goes to sleep, but that was it - the advanced settings are all default.

       

      This is what I get when I go into an elevated command prompt and use "powercfg -requests":

      SYSTEM:

      [DRIVER] High Definition Audio Device (HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS_1462D693&REV_1003\4&7752dff&0&0001)

      An audio stream is currently in use.

      [DRIVER] USB Audio Device (USB\VID_0556&PID_0001&MI_00\7&139fc4ee&0&0000)

      An audio stream is currently in use.

      [DRIVER] Legacy Kernel Caller

       

      I made sure I have the latest audio driver.  Note that in the beginning I had the latest Realtek driver, but my speakers were buzzing really bad, so I got the latest windows HD audio driver instead (which fixed the buzzing).

      I checked my sound settings - I did have duplicates of unused items (namely AMD display audio items) so I disabled those, but to no avail (everything else was normal).

      As part of my troubleshooting I did at one point re-get the latest Realtek driver, but that didn't change anything (it simply listed that in the powercfg listing instead...now I'm back to the HD audio driver).

       

      I tried adding all 3 of those items to the override list, so now in elevated command prompt if I use "powercfg -requestsoverride", I get this:

      [DRIVER]

      High Definition Audio Device SYSTEM

      Legacy Kernel Caller SYSTEM

      USB Audio Device SYSTEM

       

      But it still will not automatically go to sleep.

      I don't see any HD Audio processes running in my Task Manager.

      I'm using the same peripherals I had before on Windows 7.

      Note that if I manually put the computer to sleep it does go to sleep and stay that way.  I can wake it up and it seems just fine then.

       

      I'm at my wit's end (hence posting here).  What else is there to try?

      Thank you very much!

       

      OS NameMicrosoft Windows 10 Home
      Version10.0.10586 Build 10586
      ProcessorAMD FX(tm)-4300 Vishera Quad-Core Processor, 3800 Mhz
      BaseBoardMSI 970A-G43 AM3+ AMD 970 SATA 6Gb/s USB 3.0 ATX Motherboard
      BIOS Version/DateAmerican Megatrends Inc. V10.0, 12/26/2012