AnsweredAssumed Answered

Wolfenstein: The New Order- Still Broken, no fix in sight. What a damn shame.

Question asked by noel177 on Jun 29, 2016
Latest reply on Jun 30, 2016 by amdpete

Hello! For reference, here are my specs:

 

 

AMD (MSI) r9 390 @ latest Crimson Drivers (16.6.2)

Intel i5 4590 CPU (quad-core)

8 gigs ddr3 RAM

Windows 10, 64 bit.

 

 

Alright. So I bought Wolfenstein: The New order for the second time. I returned it a bit after launch, because the game ran miserably. Guess what? It still does, years after release.

I've tried some unofficial patches, like the VOKSI "fix" and some launch codes in steam. I've lowered the settings, turned off V-sync, and made some pretty unacceptable compromised in hopes of finding a fix. No avail. That's why I am here.

 

Contrary to popular assumption, I'm not here just to complain. I have noticed something with monitoring software that might help my fellow AMD Wolfenstein fans finally find a fix.

 

When running the game, the Vram usage of the card is pretty close to constant, with only a couple of minor bumps here and there. However, what is really interesting is that the GPU usage shifts dramatically while playing the game. By drastically, I mean from 80-0% in a matter of seconds during gameplay. The frame rate, all the while, fluctuates painfully from 49 to 22 fps on medium to ultra settings, with minimal differences between settings. This is unplayable, and for a game that looks so average, this is unacceptable.

 

Is there a fix for this out there? Or is this something software related that requires a patch? Or is this just a side-issue?

 

Thanks!

Outcomes