AnsweredAssumed Answered

Windows 10 apps Crashing with Radeon HD7870

Question asked by realperfect on Jun 28, 2016
Latest reply on Jun 30, 2016 by realperfect

Hello there,

I'm having a really annoying problem with my Radeon HD 7870 Sapphire Ghz Edition.

Every time I try to watch a video using an Windows 10 app that enbedds a video like streams those apps crash instantly. The same issue occurs trying to launch Forza Motorsport Apex from the Windows Store, after the first initial loading screen the game crashes. The same happens again, when I start streaming from my Xbox One via the xbox app.

It though WON'T happen using in a Win32 application like Chrome, VLC or streaming from my PS4 using Sony's streaming client, neither playing any video game like Assetto Corsa.

It seems only to be an issue with UWP / Modern UI apps, but since I changed the graphics card to my prior HD 5850 and all worked fine, I hope to find the answe in this forum. Changing the graphics card back to the 7870 brings back the problem.

 

My system:

  • Windows 10
  • AUS P7P55D Mainboard
  • Intel Core i7 860 @ 2,80 GHz
  • Sapphire AMD Radeon HD 7870 Ghz Edition @ PCI Express 2.0 x16
  • AMD Crimson 16.15.2211-160321a-301173C
  • 8GB RAM

 

I tried some possible solutions so far but nothing helped:

  • reinstalled different driver versions including the last catalyst control center version 15.7.1. instead of crimson,
  • reinstalled several versions of the MS C++ Redistributable (2008,2010,2012,2013,2015)
  • tried to repair some libs using sfc /scannow, which idneed found corrupt opencl.dll and fixed it but with no effect on that issue.
  • reinstalled the crashing apps
  • disabled ULPS in Sapphire TRIXX (discovered that the GPU voltage won't be displayed, says "0"?)
  • changed the graphics card to my prior HD 5850 and all worked fine
  • Using GPU-Z I discovered that starting a video boosts the memory clocks from 150 Mhz to 1200Mhz syncronious to the app crashing.
  • I monitored the other sensors and GPU core clock is in idle at 300Mhz, mem clock at 150Mhz, temp at 28°C and voltage is between 11.88 and 11.91V, VDDC is around 0.820V (I don't know if this ok?)

 

Can someone help please?

Attachments

Outcomes