41 Replies Latest reply on Jul 20, 2016 4:10 PM by iainob1

    yet another bug with the r9 295x2 latest drivers

    iainob1

      The loosing monitor signal and crash is back again with the latest driver but in dx 9 only.

       

      Running Heaven becnhmark in dx 9 mode and in windowed mode causes my system to lock up. doing it every time now

       

      Sometimes it will just lock up and I have to reboot and other times it locks up and my monitor goes into standby and looses signal.

       

      DX 9 is well and truely broken in all drivers for the r9 295x2

       

      So far this bug now adds to a long list of bugs rendering this card totally useless in Windows 10.

       

      When is AMD going to offer me a replacment card that has fully working drivers for windows 10 so I can actually game properly and get what I have paid for? It is drivers that are causing the issue and have rendered my card usueless for gaming.

       

      There is not a single working driver for the r9 295x2 for windows 10. Catalyst and Crimson all have various combinations of the same bugs and faults.

       

      I have tested them all.

       

      Core clocks downclock and fluctuate when crossfire is disabled. 100% repeatable.

      Core clocks downclock and fluctuate when using boarderless fullscreen, 100% repeatable.

      All dx 9 titles have stutters and hitches. all drivers

      Last 3-4 drivers  now have flashing lights and shadows in dx 9 games

      Many of the drivers will not let you disable crossfire for dx 9 games.

      The drivers that do work disabling crossfire for dx 9 all then have the usage on the one card fluctuate and spike up and down from 0 to 100 constantly.

      Blackops 3, still can't run the game in fullscreen without having the flashing shadows, crossfire on or off. All drivers

      Many drivers cause the system to freeze and loose signal with the monitor.

      All  crimson drivers have introduced hitching and minor stutter that was not there in the catalyst drivers.

      Anistropic filtering in games has very obvious boarderlines between the different levels of filtering usually around your character in the game. All drivers.  These are not obvious on my Nvidia card.

      When crossfire is disabled the card that it disabled still gets a little usage from time to time and also the clocks fluctuate on that disabled card too. The temperature of the disabled card is often higher than the card with the actual usage.

      VSR enabled causes my monitors native resolution to be not available in a few games.

      VSR resolutions cause game menus to not be usable in many games. Scalling options do  not fix these problems.

       

       

      ULPS is always disabled.

      Power settings are at full.

      The r9 295x2 does not have power effeciency settings only introduced after 300 series.

       

      Non of the issues with dx 9 are there if I use my older gtx 680ftw. DX9 games such as Skyrim, Raceroom, Xrebirth, Arma 2 all work very smooth on the gtx680 in the same system, no stutters or hitching. The r9 295x2 just does not work with dx 9 properly. The bugs must be deep routed in the drivers as they have been there for so long.

       

      I have bug reported many times and there is never any recognition of these bugs.

       

      I know there are newer cards now and my r9 295x2 is getting older but it is not acceptable for a then flagship product, to be rendered unuseable by drivers and for it to go on so long without either being fixed or AMD publicy acknowledging these issues and that they are working on a fix.

       

      This is not a device issue or to do with how my system is set up it is very clearly 100% broken drivers.

        • Re: yet another bug with the r9 295x2 latest drivers
          noxlar

          so you have a lot of problems with your 295x2.  i have sapphire 295x2 with asus crossair v formula z and amd 8350 cpu.  and i have to say i have never had any problems with drivers, games og benchmarks. at least with this card other then the problems when i bought the card but everything went nice after getting a new 1200w psu.. only problem i have is the fan regulator is removed by amd in its drivers.. but that is okay, let the temp regulator control that.  it would be okay if the fan did'nt stopped at 33% . i have tried pushing the best i can to make it use one more %.  so i wonder if my card should behave like that

            • Re: yet another bug with the r9 295x2 latest drivers
              iainob1

              I also thought all the issues could be psu based but i have a 1200w psu and it was an AMD recomended one specifically for the r9 295x2.

              The lower supply is working fine and as most of the issues are to do with dx9 it has to be drivers.

               

              The card was working great in win 7 and 8. All the same hardware. All the dx 9 games ran great.

               

              my windows 10 is a clean install and all drivers for bios, chipset, and motherboard are all up to date.

               

              can you test some dx 9 games and see if you get some of the same issue. Specificaly look at the cards usage and clicks when you disable crossfire. Test skyrim if you have it and see if you get the hitches and stutters.

            • Re: yet another bug with the r9 295x2 latest drivers
              iainob1

              Can also add blue screen crashes with driver failure with the latest driver return to last and its gone.

              • Re: yet another bug with the r9 295x2 latest drivers
                noxlar

                i had an very good 850w psu, but as an hardware safety feature (just guessing) when the card didn't get the required amp my card at least never activated gpu2 and the gpu1 only ran at about max 70% utilization, but still, my system was rock solid stable. and fast, faster than my previous 7970 1ghz card. but after awhile i wanted to overclock to get more performance, be course it should be faster so i did OC it, but the pc shuts down instantly, so after that i tried to get to the bottom what was happening,  so after much research i figured it had to be the psu.  so i went for corsair ax1200i.  i haven't yet figure out the software control over psu, but i think it is getting the power it wanted.

                 

                test dx9 game, sure. witch one?   sorry about the delay, but im working away from home.

                  • Re: yet another bug with the r9 295x2 latest drivers
                    noxlar

                    okay, now i have tested skyrim,crysis,warcraft3,call of duty1,farcry1, Heaven benchmark in dx9 ultra settings,fullhd stable 110-120 fps every game crossfire enabled, only warcraft didn't use it, but that is dx8. no problems changing resolution,changing games, or anything. just perfect i would say. if you want me to test anything else og something else, let me know,

                     

                    but i would guess it missing power, the symptons you describe totaly macht my old psu, You also need to make sure at least 28 amps are supported on each 12V rail.

                     

                    from hardtop site:

                     

                    If you have a proper PSU for this to work make sure you follow the diagram above in the PDF. You cannot use both power connectors on a cable that splits off into two, or shares the 12V rail with any other component. You need dedicated 8-pin connectors to each video card. You also need to make sure at least 28 amps are supported on each 12V rail. If these factors are not maintained, wire overheating and melting situations could occur. Beyond that, you will also need the proper wattage to support two of these video cards, and it is a lot. 1500W is suggested at the least.

                     

                     


                     

                     

                    The PSU Wattage Problem

                     

                    In our evaluation system we are using an Enermax MaxRevo 1350W PSU. This is a beefy power supply that has served us well in testing and has allowed us to use any combination of video cards, up to 4 GPUs on previous generations without issue. In fact, the max support amperage is 30 amps per 12V rail, so the ratings in terms of amps are than what AMD recommends. We had no issues with this power supply and one AMD Radeon R9 295X2 video card. However, we did have problems with two.

                     

                    The problem was a simple one to diagnose, we ran out of wattage. Our 1350W was not enough to run two AMD Radeon R9 295X2 video cards in CrossFire on our overclocked system. Note that our system runs lean, we do not have an optical drive, we have only one SSD, everything on the motherboard is turned off except what we need. The two major power drains are our CPU which is an overclocked Intel Core i7 3770K at 4.8GHz and the GPUs. 

                     

                    The issue we ran into was that the games would start just fine, but as we got going the wattage increased on our power meter (at the wall) until it rose above 1350W and the PSU would then shutdown. We needed more wattage to make gaming work, simply put. Since we were under a very strict time scale to complete our testing, and because we did not have a spare 1500W PSU on hand nearby we made this work in another way.

                     

                    HARDOCP - R9 295X2 QuadFire - AMD Radeon R9 295X2 CrossFire Video Card Review

                      • Re: yet another bug with the r9 295x2 latest drivers
                        iainob1

                        When I original bought the card I researched the power supplies and got one actually recommended by AMD specifically for this card.

                         

                        https://www.amd.com/Documents/Selecting-a-System-Power-Supply-for-the-AMD-Radeon-R9-295X2-Graphics-Card.pdf

                         

                        I have the 1500w Strider gold which has two rails capable of supplying the correct amps on each rail. Each cable to the card is coming from separate rails

                         

                        The card works fine for dx 10 and 11 just not for dx 9 in windows 10. Also win 7, 8 and 8.1 were totally fine.

                         

                        The last two drivers have reintroduced the random black screens when using the dp port. This stops when using the dvi.

                         

                        This is not there in previous drivers for me.

                         

                        All dx 9 games don't work properly for me they all have hitching and stutters. Many of the drivers have a bug where crossfire will not disable for dx 9 games.

                         

                        The drivers where it does disable causes the one cards usage to fluctuate and spike up and down from 0 to 100 constantly.

                         

                        Again this does not happen in dx 10 or 11.

                         

                        Also non of these issues where there in previous windows. win 7, 8 and 8.1 were totally fine with all the same hardware. In fact up until windows 10 this card had been the best I have ever used. Every game just worked.

                         

                        I have tried many re installs of everything, including win 10, drivers, motherboard drivers, intel inf's the whole lot.

                         

                        If it was the power supply then it would not be just be dx 9 that has problems.

                         

                        It may be just a win 10 driver that is somehow causing problems on my system and is causing dx 9 to crap out.

                         

                        Skyrim runs and appears smooth but then you move down the path to the next cell and then the stutters start. Inside building when facing certain directions I get

                        strange microstutters. Always facing the exact same ways. These stutters can be sort of stopped by using dxtory and capping at 60hz but then i get bigger freezes and hitches then randomly. The way memory for dx 9 is used has been changed in win 10.

                         

                        If you can disable crossfire for skyrim and then watch your gpu's usage. Also see if yours has signs of stutters and hitching.

                         

                        Skyrim radeonpro.JPG

                         

                        That is skyrim on my system when crossfire is disabled. Again only a couple drivers actually work disabling crossfire. Notice how gpu 2 which is disabled has a higher temp than card one with the usage.

                         

                        Every dx 9 game is like that.

                         

                        bo3 crossfire off.JPG

                         

                        That is bo3 with crossfire turned off just to show the difference.

                         

                         

                        I have monitored my psu during full load and it is stable no fluctuations.

                         

                        This is simply driver problems with the drivers and my system and windows 10.

                         

                        Your lucky if you are not seeing these issues as it has plagued my gaming since windows 10 came out. Every drivers has things slightly different but all have issues for me.

                         

                        My next step is to go back to win 8 and show that everything runs fine again.

                         

                        When crossfire is disabled on any game the core clocks do not stay at full they fluctuate all the time and sometimes drop to 2d rates. I have to use clock blocker every time to keep them at full. See if you can also test this.

                         

                        The same goes for using windowed mode or boarderless full screen because they disable crossfire. This is 100% repeatable.

                         

                        Only leaving crossfire at default will the clocks stay at the full 1018.

                         

                        Thanks for testing things.

                    • Re: yet another bug with the r9 295x2 latest drivers
                      noxlar

                      Screenshot-Capture.2016-07-07.jpg

                      hi . i started heaven in dx9 mod, default settings in radeon setting only turned of crossfire, is it normal here?  i was wondering if we should look at what kind of software we use and perhaps find the difference or solution that way. are you intel og amd cpu?

                          • Re: yet another bug with the r9 295x2 latest drivers
                            iainob1

                            I'm on an i76700k

                            Asus viii ranger maximus

                            16 gb ram

                            Ive just done another full fresh install of windows 10 all drivers up todate will download the heaven again and see what happens. will report back cheers for doing that.

                              • Re: yet another bug with the r9 295x2 latest drivers
                                noxlar

                                wich windows did you installed?  and whats the name of your psu

                                  • Re: yet another bug with the r9 295x2 latest drivers
                                    iainob1

                                    Ok so I installed win 10 again from scratch.

                                     

                                    Installed all drivers and updated windows fully before installing the new drivers from amd.

                                     

                                    Put the heaven benchmark into dx 9 version and ran it first in crossfire on.

                                     

                                    I get very high fps but it still hitches every few seconds. These are like mini freezes and then it jumps forward. Must have done it around 30 times during the benchmarking cycle.

                                     

                                    I then ran it again with crossfire disabled.

                                     

                                    The fps fluctuate quite dropping below 60 fps at the beginning. Also the core clocks drops every now and then and it does not sit at full the whole time.

                                     

                                    dx9 crossfire off.JPG

                                     

                                    You can see the core clock drop above during the test, again there are little hitches every now and then. Every time it does this with dx 9 and also in general if crossfire is disabled. Also for some strange reason it shows the usage on card two when usually its on card one. The drivers just do not work with my system. The usage sat at 100% most of the time which it will do with benchmarking software. Using normal games the usage does not always sit at 100% so when crossfire is disabled the core clocks drop and fluctuate all of the time. Either the card I have is faulty or it simply is just the drivers. As each driver causes different things to happen it has to be crappy drivers, which will work with some peoples systems but not everyones.

                                     

                                    Every driver has the core clocks downclock in full screen mode if crossfire is disabled.

                                      • Re: yet another bug with the r9 295x2 latest drivers
                                        iainob1

                                        vrtest.JPG

                                        There is my VR test too.

                                        • Re: yet another bug with the r9 295x2 latest drivers
                                          noxlar

                                          hmm, since all of the drivers fail and only windows 10 related, my best guess it must be some feature windows 10 must be activated or disabled. i don't think its the drivers at all.  is it 64bit win10 pro?  and i would searched your mainboard+win10 issues

                                            • Re: yet another bug with the r9 295x2 latest drivers
                                              iainob1

                                              Running in dx 11 too has the core clocks downclock with crossfire off. These drops also match exactly when the frame times shoot up.

                                               

                                              I have the 64 bit pro version of windows 10.

                                                • Re: yet another bug with the r9 295x2 latest drivers
                                                  noxlar

                                                  just searched for tips on google, im writing it down the tings i find.

                                                   

                                                  [Official] AMD R9 295X2 Owners Club - Page 247

                                                   

                                                  do you have integrated graphics card on your motherboard? one person fixed the lagging by disable intregrated gpu.

                                                  and have you tried another pci-e port? 

                                                  the 295x2 requires a 16 lane slot 

                                                   

                                                  So here is what to do:

                                                  1- in MSI Afterburner (you do have it, right?), disable ULPS. It's a box to checkmate in the General tab. You may need to restart after this.

                                                   

                                                  2- open up Catalyst Control Center, under preferences and make sure Enable System Tray Menu and Advanced View.

                                                   

                                                  3- open the Performance tab on the left side column of the CCC. Click AMD CrossfireX. Make sure to activate (check mark) Enable AMDCrossfireX. Only Win8'users will get the further option of Enabling CrossfireX for programs that have no profiles... SELECT THIS. if you need to disable this for a program, you will need to Should you wish to disable crossfire for a specific game you need to create a specific profile within 3d applications and select the game exe, add it, then disable crossfire and click apply.

                                                  Apply changes.

                                                   

                                                  4- Click the Gaming tab in the left-aided column then click 3D Applications. Verify that Frame Pacing is enabled. Click apply and X out. (Close CCC).

                                                   

                                                  5- Go to Right Click the CCC icon in your taskbar. Go to 1.AMD Radeon R9 295x2 >> AMD Crossfire Settings>>>Show CrossfireX Status icon. Make sure it's checked.

                                                   

                                                  Now, whenever a 3D application loads, if Crossfire is working, a logo will appear in the upper right corner of your screen. All your GPUs should be running at same % rate at each cards's maximum boost and clock.

                                                    • Re: yet another bug with the r9 295x2 latest drivers
                                                      iainob1

                                                      Yeah but I always have it disabled in windows. I don't think it can be totally disabled from the bios you can have it set on auto or choose which one is detected first but I don't think it can be disabled fully.

                                                       

                                                      I havnt tried a different port as only one port is pcie 16

                                                        • Re: yet another bug with the r9 295x2 latest drivers
                                                          noxlar

                                                          only one pci-e 16x... are u sure your pci-e port has 16 lanes? check manual

                                                            • Re: yet another bug with the r9 295x2 latest drivers
                                                              iainob1

                                                              Yeah if you use the second one it drops down to 8. Even says in the bios to use the first pci-e slot for one card.

                                                                • Re: yet another bug with the r9 295x2 latest drivers
                                                                  iainob1

                                                                  Looks like the mini display ports are the cause of the random black screens every one of them goes black if you move the cable slightly in the socket. Its the same for them all. Sometimes the screen does not come on until you move the cable again. Poor quality xfx dp ports.

                                                                   

                                                                  At least Matt has acknowledged they are looking into the downclocking issues as people are having them with freesync and crossfire now.

                                                                   

                                                                  The issues are all driver issues in the end, yes it may be different because of everyones slightly different hardware combinations but it is simply down to AMD drivers that the card behaves in aa certain way. The AMD drivers are treating crossfire off as though its a 2d application and as soon as the usage drops below 100 the clocks then also downclock.

                                                                  • Re: yet another bug with the r9 295x2 latest drivers
                                                                    noxlar

                                                                    i think you should read this.. it may solve it..

                                                                     

                                                                    https://www.reddit.com/r/pcgaming/comments/2sg2zj/psa_double_check_your_gpus_bus_interface/

                                                                     

                                                                    it was so much reading i had to take a break hehe

                                                                    • Re: yet another bug with the r9 295x2 latest drivers
                                                                      noxlar

                                                                      your 295x2 uses 8x for each gpu, but use cpu-z to see if it is configured as pci-e 2.0 16x

                                                                          • Re: yet another bug with the r9 295x2 latest drivers
                                                                            noxlar

                                                                            Stutter fix for AMD CrossFire.

                                                                              After testing a lot of things, i finally fixed it.

                                                                            Run the game as DX9.
                                                                            On CCC, set BioShock CrossFire Profile for Far Cry 3.
                                                                            Set watter effects on Low. Everything else on ULTRA (if you RIG can hold it).
                                                                            Use MSI Afterburner (or any other program) and set frame rate limit to 60 FPS.
                                                                            With BioShock CrossFire Profile I get 1.5x more FPS.
                                                                              am playing with 3 monitors @ 5760x1080 and I have NO stutter.

                                                                            ---------------------------------------------------------------------------------------------------------

                                                                            another possible fix.

                                                                             

                                                                            either way fallout nv will run on ultra no worries with just a single 7950. so if you see stutter, just disable crossfire. ,microstutter is not resolved in dx9 titles this is true, but another way to remove microstutter completely is to enable vsync, and keep your fps high enough to be hitting vsync most of the time, which they would certainly do in that game, either that or a frame rate limiter if you dont like vsync.

                                                                            ---------------------------------------------------------------------------------------------------------

                                                                            and another:

                                                                             

                                                                            I saw this suggestion on another forum after weeks of searching for a stuttering fix. This fix worked FOR ME I can't guarantee it will work for you but feel free to try: (For nvidia) Go into the nvidia panel and edit FC3's settings, enable triple buffering and set vertical sync to "on". Then, inside of FC3 set vertical sync to 1 frame. For some reason when vertical sync is enabled in BOTH the nvidia panel AND in the game, it eliminates stuttering, even if you have only around 30 FPS (like I do on my GTX 460) and it eliminates that awful screen tearing! If I turn on vertical sync only in the game or only in the panel, it stutters WAY more than if I just leave it all off, but for some reason enabling both stops stutter completely. Feel free to try it! And if you have AMD try it and see if it works for you too. Also this might help, might not, I'm not sure, but if all else fails, try capping your framerate to 60 also, that might help.

                                                                              • Re: yet another bug with the r9 295x2 latest drivers
                                                                                noxlar

                                                                                i took a look at ULPS issue and i found this:

                                                                                --------------------------------------------------------------------------

                                                                                How to Disable ULPS on AMD Crossfire Setups

                                                                                 

                                                                                Introduction

                                                                                Why would you want to Disable ULPS? If you have two AMD card's in crossfire, it probably has ULPS enabled. ULPS disables the second GPU when not in use. This is alright but sometimes it causes issues in overclocking and/or playing certain games. It can also cause other problems do for troubleshooting purposes, it is recommended to disable ULPS.

                                                                                 

                                                                                Step 1

                                                                                Go to the registry by typing "regedit" in windows search.

                                                                                Step 2

                                                                                Go to the "Edit" tab and click on "Find".

                                                                                Step 3

                                                                                In the text box type in "EnableULPS" and then press Find.

                                                                                Step 4

                                                                                You should see "EnableULPS". Double click on it.

                                                                                Step 5

                                                                                Change the value from "1" to "0"

                                                                                 

                                                                                Recap

                                                                                ULPS should now be disabled. Although you can opt to disable it in Afterburner and Catalyst Control Center, it often gets turned back on after an update and so doing this is more efficient.   Note: If you want to turn ULPS back on, simply change the value back to "1".

                                                                                ---------------------------------------------------------------------------------------------------------------------------------------------------

                                                                                 

                                                                                i know mine is off, in after burner is says it is deactivated, so i went checking regedit, it turns out it is defaulting to on every time you starting windows

                                                                                 

                                                                                maybe this helps

                                                        • Re: yet another bug with the r9 295x2 latest drivers
                                                          iainob1

                                                          I notice in your screen capture when youwere running heaven with crossfire off your clocks also have fluctuations and down clocks. Thoses little spikes down on the core clock are the same as mine when crossfire is disabled. This has been a bug with our card for a very long time.

                                                          in benchmarking software they tend to push the usage up to full so the fluctuations are not as bad as gaming in general whic sees more and bigger fluctuations due to usage dropping from 100 more often.

                                                      • Re: yet another bug with the r9 295x2 latest drivers
                                                        noxlar

                                                        yea, your psu is good enough, you could basically have two 295x2 card   if your sure you do have used to different rails, its not easy to tell sometimes. corsair uses one rail but with their software i can make more rails available if i have too, at least they say so, i haven't figure it out yest, but since i get all the amps with one rail it must be okay.  i don't have many dx9 games, i thing my skyrim is dx10, its the legendary version.. i don't know.   and if you see the windows i'm using, its the insider preview not so old one. and i have tested every ati drivers out there and every beta, im using that now.   but it could be your bios config also, you have advanced power controller settings there, i haven't touched mine, and i haven't installed any overclock or mainboard software in windows.  but i used gpu driver removal tool every time there is a new driver

                                                        • Re: yet another bug with the r9 295x2 latest drivers
                                                          iainob1

                                                          Ulps is always disabled every time I re install a driver in the registry, there are many registry entries you have to change to 0, which afterburner doesn't do.

                                                           

                                                          locking the fps to 60 using after burner always causes a constant tear line in he middle of the screen as the card is not syncing to 60hz but rather 59.something which means it is always ever so slightly out. If i used to limit fps to 60 using my gtx680 It would match the 60htz and there would be no tear line. its always out of sync with the Amd card.

                                                           

                                                          My pcie settings are always at x16  3.0 and is set to gen 3 in the bios.

                                                            • Re: yet another bug with the r9 295x2 latest drivers
                                                              noxlar

                                                              okay then, did you try RadeonPro? i know development have stoppet for some time, but people have success with win10 64bit

                                                                • Re: yet another bug with the r9 295x2 latest drivers
                                                                  iainob1

                                                                  yeah I have tried Radeon Pro used to use it a lot before.

                                                                   

                                                                  Taking Skyrim for example.

                                                                   

                                                                  No mods and even using the low textures the game still has freezes and hitches. This happens especially when you walk into the next cell or ugrids.

                                                                   

                                                                  On my gtx 680 on the same system the new scenery of the next cell or area fades in smooth. Using the r9 295x2 the game freezes for a split second and then the next bit of scenery snaps in.

                                                                   

                                                                  Again this does not happen on win 7 or 8 or NVidia on all windows.

                                                                   

                                                                  Walking down to whiterun from Helgen has many stutters and split second hitches. All dx 9 games only have these but skyrim is the worst. Any time something loads in or just randomly.

                                                                   

                                                                  DX 10 and 11 games are all fine very smooth. No amount of tinkering with settings or using third part programs every changes anything the effects are exactly the same.

                                                                   

                                                                  It has to be to do with crossfire and how it is not working properly for dx 9 and also how the memory is used as anything loading in causes hitching. Again this is not a hdd issue as it does not happen ever with dx 10 or 11.

                                                                   

                                                                  Disabling crossfire causes core clocks to fluctuate and downclock, sometimes crossfire can not be disabled for dx 9 games for certain drivers, it all has  to be linked and it is a driver issue plain and simple. Its also strange how when you do disable crossfire for dx9 the one card usage isn't correct and spikes up and down from 0 to 100 as though the other card is still somehow effecting it. It is all not right and needs looking into it has gone on far too long. Nothing I do my end will fix this. Nvidia works fine if I swap the cards over from the lads pc it works right away. dx 9 runs smooth I can run skyrim perfect.

                                                                   

                                                                  If it was my system all dx versions would be effected but its not.

                                                                   

                                                                  The only issue that is in all dx versions is the downclocking of core clocks when crossfire is disabled and or using any of the windowed modes.

                                                                    • Re: yet another bug with the r9 295x2 latest drivers
                                                                      iainob1

                                                                      Skyrim crossfire disabled broken.JPG

                                                                       

                                                                      Dx9 still broken in the new hotfix drivers,

                                                                       

                                                                      again Skyrim above crossfire disabled.

                                                                       

                                                                      The usage on the one enabled card fluctuates from 0 to 100.

                                                                       

                                                                      The core clocks downclock constantly sits between 300 MHz and 800mhz at full screen

                                                                       

                                                                      Again only dx9 games have this. I believe crossfire is still broken in dx 9 and is either not disabling fully which is causing the usage to fluctuate like that.

                                                                       

                                                                      All of the stutters and fps drops in game are the result of this. Dx 9 is broken for the r9 295x2

                                                                        • Re: yet another bug with the r9 295x2 latest drivers
                                                                          iainob1

                                                                          Skyrim and Raceroom in the same graph

                                                                           

                                                                          skyrim and raceroom.JPG

                                                                           

                                                                          Because the card does this with dx 9 the temps never go above 40c.

                                                                           

                                                                          The clocks sit between 500 to 800 never going above.

                                                                            • Re: yet another bug with the r9 295x2 latest drivers
                                                                              iainob1

                                                                              Testing skyrim on both redeon pro and just amd ccc.

                                                                               

                                                                              In game you can see that the temps on the disabled card are either the same or sometimes higher than the card that is supposed to be active and have the usage.

                                                                               

                                                                              The usage fluctuations are from 0 to 100 and in between, every second its very regular.

                                                                               

                                                                              I think the issue is that crossfire is not disabled or disabling properly for dx 9. Even though we only see the usage on one card in fact it must still be effecting the other card in some way. That must be why I am seeing the temps to be acting strangely. Also it may be why the usage fluctuates as it is trying to use the other card in some way.

                                                                               

                                                                              In normal usage and in dx 10 and 11 when disabling crossfire only one cards temperature would rise and it would be a way above the disabled card. For some reason in dx 9 this does not happen.

                                                                    • Re: yet another bug with the r9 295x2 latest drivers
                                                                      srs13rastus

                                                                      Try running the MS TdrDelay regedit fix, sorted all my BSOD/Freeze issues an I'm running 2 8GB 290X's

                                                                       

                                                                      Windows 10 - Display driver has stopped responding and has recovered - - Microsoft Community

                                                                       

                                                                      Had crossfire problems and managed to fix it by removing 2nd GPU and doing a uninstall and reinstall of 16.3.1 then the 16.7.2 hotfix can't do that with half a 295X2 though sadly.

                                                                       

                                                                      Crossfire Option Not Showing Up Even Though Everything Is Put In Correctly.

                                                                       

                                                                      The TdrDelay SHOULD help with the other problems though...

                                                                        • Re: yet another bug with the r9 295x2 latest drivers
                                                                          iainob1

                                                                          The tdrdelay makes no difference to the broken drivers unfortunately. I have changed the settings and nothing is different.

                                                                           

                                                                          Basically in a nutshell

                                                                           

                                                                          freesync + crossfire = core clocks downclock and fluctuate around 2d rates.  Clock blocker only forces the clocks on one card now with freesync enabled.

                                                                           

                                                                          crossfire disabled + freesync on or off = core clocks downclocking and fluctuating

                                                                           

                                                                          DX9 stutters and hitching, crossfire not working properly or not disabling properly, usage on the one card fluctuates up and down from 0 to 100 constantly when crossfire is disabled. This has gone on wince windows 10 came out. People with single cards don't have these issues, its only on the r9 295x2. DX 10 and 11 is fine, unless disabling crossfire which causes clocks to downlcock

                                                                           

                                                                          Every driver has an issue with the r9 295x2. Amd need to pull their finger out and start actually fixing these issues instead of ignoring them.

                                                                           

                                                                          Again put the gtx680 back in the system all problems are gone with every game.