2 Replies Latest reply on Dec 22, 2016 9:43 AM by mnmlguy

    Screen flashing and flickering and making my PC Freeze

    kyleshupe

      Hi i own the ATI AMD Radeon R7 200 Series and recently i have been having issues with my screen freaking out and going all black and white, i have the driver version 15.300.1025.1001 and then it causes the graphics card to freeze then causing my PC to freeze and then shut down and turn back on. HELP! it doesn't do this in games at all. it only happens when i'm using chrome or like Skype and just basic apps like those. Usually there's no way i can fix it except restart my PC !

        • Re: Screen flashing and flickering and making my PC Freeze
          amdmatt

          Please try the steps below to see if it resolves the issue.

           

          1. Run the Windows self check tool to check scan and automatically repair any corrupt files found in Windows. There is a guide on how to do it here.  What you need to do is run an elevated command prompt (elevated means run it as administrator) and type SFC /SCANNOW. This will generate a statement indicating if errors were found the Operating system and if they were fixable.

           

          2. Make sure you have installed Microsfot NetFramework and Visual C++ 2013. These should be installed already, but they can become damaged, need repairing or reinstalling.

           

          3. Update Windows. Install all available critical, recommended and optional updates. Often Netframework and Visual C are included in the recommended or optional updates Windows provides. Windows should always be fully up to date before installing our drivers!

           

          4. Use DDU to sweep the system of AMD drivers.

           

          5. Install the latest Crimson 16.6.1 drivers once the above is completed and check to see if the issue is resolved.

          • Re: Screen flashing and flickering and making my PC Freeze
            mnmlguy

            I have the exact same issue for a few months now on Sapphire 7870 GHz Edition. It happens on random occasions with Skype and only on fresh start. The only way I could reliably trigger the issue is with Thunderbird with enabled hardware acceleration. Most of the time the screen would just glitch-out for a moment when I open Thunderbird for the first time. But some times it would totally mess up my screen and I need to restart or shutdown with keyboard shortcuts. I've did all the steps amdmatt suggested but the issue still remains.

            My specs:

            OS: Windows 7 64bit

            CPU: Intel i5-3570k @ stock

            MB: AsRock z77 Extreme4

            RAM: 2x4GB DDR3 Mushkin Blackline 2133MHz

            GPU: Sapphire 7870 GHz Edition 2GB GDDR5

             

            Here's how the issue looks like:

            IMG_20161129_122349.jpg