3 Replies Latest reply on Jun 21, 2016 7:48 AM by kingfish

    USB ports 2.0 & 3.0 not working after AMD Catalyst uninstalled, Windows 10

    shofixti

      Hello community

       

      I upgraded from a 7800 series video card to a GTX 970 yesterday. It seemed a prudent idea to uninstall catalyst as I wouldn't be using it anymore.

      I used AMD's own function through the Windows 10 add/remove programs facility.

       

      But now I find that none of the USB ports work after a reset. The PC can detect the keyboard via USB (and will alert the user if it cannot detect one) but once Windows is engaged they go dead and nothing lights up and nothing responds. I cannot fathom how an industry leader like AMD could have a software uninstall facility like that that will completely render a PC useless.

       

      I have one ps2 port, and I went to a local service desk and they let me borrow the ps2 keyboard. But I could not remedy the situation. I connected to their network and tried to activate new drivers, tried to uninstall and re-detect hardware changes, I even tried to reinstall the catalyst software. This was very hard to do just Tab navigating around with no mouse.

       

      In the end I had to give up. I booked a tech for a visit tomorrow, but they may have to extract the HDD and install it elsewhere to get a result. (This will cost >$125NZ so any help would save me a lot)

      I had also contacted Microsoft - seems that another option is to buy a new HDD and transfer my Windows licence to that, in the hope that it will correctly engage the USD drivers.

       

      At the moment I cannot figure out how others have resolved this issue beyond simply locating a ps2 keyboard. My Windows 10 said there was no restore point to go back to.