10 Replies Latest reply on Sep 21, 2016 6:10 PM by thwomp

    Mirror's Edge Catalyst Says i need my driver updated to amd Crimson 16.6.1 for the game to work.

    mahesxaxagaming

      Ive downloaded The update SEVERAL times and tried to install it, and all i get is the amd window poping up saying its analyzing system then installing drivers and updating and stuff. then after i click finish when prompted, it just closes the window and nothing has changed, i look at my driver and its still at the same version it was previously, which is still 15.6. It wont let me update the driver and it doesnt promt me saying it failed to update or anything. ive tried going threw the amd autodetect and it says that 15.6 is the most up to date driver i can get. i have an AMD Radeon HD 5700 Series Graphics card, if anyone can help me, that would be much appreciated. And by the way, I was able to play Mirror's Edge Catalyst fine with the driver i had, and they updated the game and now it says i need the new driver, I've been trying for about 4 hours now trying to update this driver and got nothing from it.