4 Replies Latest reply on Dec 4, 2016 8:59 AM by enemymind

    R9 390x Driver crashes


      MSI R9 390x

      Driver version: 16.200.1025.0

      Win 10 Pro 64bit

      Using HDMI too a 1080p 60Hz LCD TV (doesn't have dvi

      MSI z97 Gaming 5 Mobo

      Intel 4790k

      EVGA 750w GQ ATX 80+ Gold

      16GB Corsair Vengeance Pro DDR3 1866Mhz (2x8)


      When I put my 390x on load (in games and bench marking software) it crashes within seconds (about 5-15 seconds in), usually after a large horizontal screen tear. Sometimes it crashes back to game and is fine for a few seconds then crashes again or occasionally it will crash to desktop and resolves itself and i get a message telling my AMD drivers have crashed etc but other times it just completely crashes and I'm left with a black screen with no signal going too the TV and have to force restart my PC every time. Either way games are unplayable, I've tried using Furmark as well as a test to make sure it isn't just the games I'm playing (at the moment mostly World of Warcraft) but that crashes within 10-15 seconds usually as well.

      Heat doesn't seem to be an issue in this as it rarely gets over 80 on full load according to my monitoring software and Furmark's temp monitor.

      Had no other GPU's in this build.


      I haven't had this card for too long but I've had no problems up until a week ago or so when this started and lasted a few hours of almost instant crashing on WoW, went out for a while came back and it worked again completely fine for 2 days after i installed the beta driver update but now its drivers are crashing again and its driving me mad I haven't installed any new programs or changed anything recently.

      I've disabled hardware accelerated graphics in my browsers as well as I've heard that conflicts sometimes with the 300 series but still no luck!


      I can't currently edit my BIOS either as my TV is my only monitor for my PC and its resolution scale in BIOS is completely unusable apart from too change the time.. so due to BIOS settings I can only use one video output at a time (i.e gpu or mobo hdmi but mobo hdmi will not work with gpu in the mobo)


      If I have missed out any information that could possibly help please let me know.


      Any help would be much appreciated so I can get back to enjoying this monster of a graphic card!

        • Re: R9 390x Driver crashes

          It`s hard for me to tell but was this the latest Driver?Because the latest driver is pretty stable.



          Mind you.I am saying stable.I am not getting the amazing speed i did in Fallout 4 and Skyrim anymore.

            • Re: R9 390x Driver crashes

              It was indeed  the latest driver off of the site but that made me crash constantly, I've now gone to driver version 15.200.1062.1003 and it seems a lot more stable, not crashing in game yet after 2 hours.

              1 of 1 people found this helpful
                • Re: R9 390x Driver crashes

                  Spoke too soon, shortly after crashing has begun again. Although I'm not sure if it automatically updated the drivers to the latest version again as since then I've been playing around with it trying to get it working (uninstalling with ddu and reinstalling drivers off site and off of provided disk) and I forgot to check last night.

              • Re: R9 390x Driver crashes



                I also have same black screen issue (no signal..only in gaming). All old and new driver doesn't works or fix it. As suggested in another thread, I raised the power target to +20% in MSI Afterburner and do TDR windows seems fixed the issue. Now i am using Crimson 16.11.5


                For TDR windows adjustment

                1. Click Start, type regedit in the Search box, and then double-click regedit.exe from the results above. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
                2. Browse to and then click the following registry subkey:
                3. On the Edit menu, click New, and then select the following registry value from the drop-down menu specific to your version of Windows (32 bit, or 64 bit):

                4. For 64 bit Windows
                  1. Select QWORD (64-bit) value.
                  2. Type TdrDelay as the Name and click Enter.
                  3. Double-click TdrDelay and add 8 for the Value data and click OK.
                5. For 32 bit Windows
                  1. Select DWORD (32-bit) value.
                  2. Type TdrDelay as the Name and click Enter.
                  3. Double-click TdrDelay and add 8 for the Value data and click OK.
                6. Close the registry editor and then restart your computer for the changes to take affect.