3 Replies Latest reply on Aug 13, 2016 11:48 AM by dms-audio

    INFO : Screen Flicking / Hiccup / Jump (Related to 2D rendering clock speed and voltage ?)

    dms-audio

      asus hiccup flickering - YouTube

       

      My powercolour r9 270 is doing exactly the same thing as this video in some games. Like the screen does a jump / hiccup.

      It does not do this on the desktop, regular apps or in Firefox both under windows 7 64 bit and Linux Xubuntu 14.04 LTS so I cannot see it being the cable or monitor.

       

      Originally on 16.3 drivers and updated to 16.5.2 and both have this issue. The new 16.6.1 drivers still have this issue. Screen hiccup occurs most obviously in GameDev Tycoon which is a chrome based (ns.js / ns.exe driven) and also on the static pre scavenge screens in the game This War of Mine.

       

      Also done a full clean install :- uninstalled fully, reboot safe mode, run ddu.exe, reboot, install new 16.6.1 drivers

       

      skylake i7 6700

      asus z170-k Latest Bios

      powercolour r9 270 2048 gddr5

       

      Graphics Card Manufacturer - Powered by AMD

      Graphics Chipset - AMD Radeon (TM) R9 200 Series

      Device ID - 6811

      Vendor ID - 1002

      SubSystem ID - 2337

      SubSystem Vendor ID - 148C

      Revision ID - 00

      Bus Type - PCI Express 3.0

      Current Bus Settings - PCI Express 3.0 x16

      BIOS Version - 015.041.000.000

      BIOS Part Number - 113-C6300100-X27

      BIOS Date - 2013/11/24 21:16

      Memory Size - 2048 MB

      Memory Type - GDDR5

      Memory Clock - 1400 MHz

      Core Clock - 925 MHz

      Total Memory Bandwidth - 179 GByte/s

        • Re: INFO : Screen Hiccup Still in 16.6.1 (Some Games)
          dms-audio

          Update on this. I have seen this screen hiccup / jump occur once in company of heroes 2 static main screen with background animation, once in firefox on earth view...

          https://earth.nullschool.net/#2016/02/27/0000Z/wind/surface/level/overlay=temp/grid=on/orthographic=-3.42,49.46,2353/loc…

           

          and once in ableton live 9 with 1 synth vsti gpu active and visible on screen. It seems related to direct 2D performance and when the 2D gpu usage goes up as demanded by some apps or games or what ever firefox is displaying. Really annoying.

          • Re: INFO : Screen Flicking / Hiccup Still in 16.6.x (Some Games in 2D rendering)
            dms-audio

            Just tried an old game. Roller coaster tycoon 2 which uses the direct 2d engine and the screen hiccup / jump occurs the same after 10 minutes play and at regular intervals. This fault seems to occur on all 2D render situations. i.e. menu screens in game, some indie games and old games that that don't need or use direct 3d but use 2d rendering, even some apps that need 2D render acceleration. This screen flicker in 2D modes has been an on-going issue for sometime for many amd cards from what I have been reading.

             

            Scrapped Roller coaster tycoon 2 since its not playable due to flicker every 10 minutes. Playing Roller coaster tycoon 3 as a test instead which uses the direct3D engine and not had any jump / flicker issues.

             

            There is something very wrong with 2D rendering that does not happen in 3D rendering from what I can see even when the usage clocks fluctuate. Is this related to the clock scaling as demand shifts ? It seems that way. I don't really want to overclock or set the power setting at max from the crimson settings since I run a ultra quiet setup and want low heat and noise but I read this has been suggested. No new vbios for my card so that's not an option.

            • Re: INFO : Screen Flicking / Hiccup Still in 16.6.x (Related to 2D rendering)
              dms-audio

              OK... Still having this issue occasionally and exhausted everything but from study it really seems a fault regarding when the card changes clock speed or memory speed in 2D mode or switching between 2D and 3D modes... This has been an old issue for years for many people from pre R9 200 series which is a refresh of the latter HD series cards that have the same issue... i.e.

               

              Occasional gltichy screen flicker on desktop? - AnandTech Forums

               

              When I was using **buntu 14.04 LTS with the older stable close source catalyst linux fglrx driver I never had an issue at all. However it now happens on new install Linux **buntu 16.04 LTS very occasionally using the open source radeon driver since I upgraded from 14.04 to the new 16.04 LTS (clean install). The same 'bug' must be in the OS radeon driver or 'workaround' is missing ?

               

              So the fix can be applied in the driver it seems as the old catalyst drivers were fine on both windows and Linux. I would like someone from AMD at least explain the exact problem. Most say its the bios and the voltage setting at lowest clock speeds when it needs to jump to next speed based on demand. Using a bios flash editor and flash tool fixes it (if you know exactly what parameter needs changing) or using the msi afterburner tool from guru3d if running windows either changing the base memory clock or upping the vcore 100mv ?? But there is no definitive answer...

               

              Next card will be an Nvidia I think even though they are the worst at opening the code to Linux devs.