AnsweredAssumed Answered

AMD HD8970m with Intel HD 4600 won't switch to AMD at Win10

Question asked by cankalay on Jun 8, 2016
Latest reply on Jun 9, 2016 by amdmatt

I have made this topic 2 months before.

 

Hello,

 

I have recently updated to Windows 10 from Windows 7, with clean install on a new SSD. I have installed latest drivers for every single hardware on my laptop. I have downloaded and installed only one game: World of Warships. Then I have optimised the game to maximum performance from catalys control center(radeon stetings). Then switched my laptop's usage to maximum performance.

 

Now since I am pretty ready to launch the game, the game has very low fps. Since i had 50-70 fps at maximum options with same hardware of mine, now it has 5-20 fps. So we all know the game runs with Intel GPU not with Amd gpu. So i am frustrated ofcourse since i can't get out of trouble with this switchable gpu nonsense everytime i try something. A friend of mine suggested me to try updating the amd driver through device manager. I found that suggestion foolish, but i just give it a go for him and boom! Game has very high fps at maximum options again! I happily played it that night, till this morning. At the morning when i started my computer, and the game without changing anything from yesterday = low fps. Working with Intel Gpu again. So i clean uninstalled Intel and Amd drivers with DDU at safe mode again, installed latest ones properly with restarts each time. Tried every single method but game just runs it on Intel gpu.

 

My Specs:

Windows 10 Pro x64

Intel® Haswell Core™ i7-4710MQ 4-Cores; 6MB L3; 2.50GHz > 3.50GHz; 47W; 22nm

AMD HD8970m

Intel HD4600

Kingston Hyperx Savage 240GB SSD SHSS37A240G

750 GB Western Digital HDD WD7500BPKX-22HPJT0

8 GB 1600 mHZ Ram

It's a laptop

 

 

Other then this, i have came up with a hotfix 2 months ago. If i plug in a HDMI cable which is connected to my TV, the AMD GPU starts working as main GPU. So i can play my games through AMD after i extract the HDMI. But once i restart the pc, i have to repeat the same thing again. I hope someone has some valid fix for me.

Outcomes