2 Replies Latest reply on Jun 7, 2016 7:44 PM by mcmoochi

    Could not get 60Hz on 4K display

    mcmoochi

      I have a Sapphire R9 290, had it for a while, worked fine. Recently I purchased a new philips bdm4065uc monitor and for the life of me I could not get it to display 60Hz, only 24Hz and 30Hz options are available to me. A quick troubleshoot:

      - I have turned monitor setting to DP 1.2

      - tried replugging the Graphics card and cables multiple times.

      - tried to reinstall AMD drivers (currently on 16.6.1). I know the monitor works because when I uninstall all the AMD drivers, it can display native 4k@64Hz perfectly. Once drivers are installed, the options for higher refresh rate are gone.

      - tried to patch pixel limit

      - tried custom resolution, after setting it to 60Hz the system become super laggy

       

      I believe this is a pretty wide spread issue, however I could not find any official recognition from AMD that it even exists. Please let me know if I'm missing something.

      • AMD Graphics Card
        • R9 290
      • Desktop System
        • Windows 10 Pro
      • Driver version installed
        • Radeon Software Crimson Edition 16.6.1
      • Display Devices
        • Philips BDM4065uc
      • Motherboard
        • Asrock Z97 Extreme4
      • CPU/APU
        • Intel(R) Core(TM) i5-4590 CPU @ 3.30GHz
      • Power Supply Unit  Make, Model & Wattage
        • Corsair 750W
      • RAM
        • 8GB
        • Re: Could not get 60Hz on 4K display
          s1lv3rvortex

          It seems like you've already done a fair amount of troubleshooting on this. I see several people on other forums(including nVidia) having the same problem. Have you already tried both the mini-DP and regular Display Ports?

           

          If all else fails, maybe a call to Phillips might yield more help...

           

          Good luck!

            • Re: Could not get 60Hz on 4K display
              mcmoochi

              I ordered an adapter yesterday, still waiting for the item to arrive. Doubt it would make much difference since the two DP cables I bought didn't work.

              Philips suggested some of the troubleshoot above. But given that without driver I was able to display 4k@64Hz, we can safely assume the screen is working as intended, so there's not much they can offer me :S