2 Replies Latest reply on Jun 5, 2016 3:44 AM by aseemdomaini

    Automatic Underclocking to half frequency using latest Crimson Software (Windows 10)

    aseemdomaini

      I recently upgraded to windows 10, first thing i noticed was all of my games were running slow. Initially i suspected Windows and disabled Xbox DVR etc etc. I found that everything runs fine after i reinstall the drivers but then again slow after restarts. Finally I found the issue : After I restart and look at the Overdrive Setting , I see that the GPU and Memory frequency are half of the default for the card. Since I was not overclocking, I never suspected this. I have a Saphire HD 7770 GHz Edition and default clock speed is 1000 MHz, but after I restart Windows, the upper limit of frequency becomes 500 MHz. If I "reset" in the overdrive settings, it goes back to 1000 MHz and the games run same as they were in windows 7.

       

      settings.png

        • Re: Automatic Underclocking to half frequency using latest Crimson Software (Windows 10)
          kingfish

          Put your power limit to +20 and your clocks to default. Your computer power plan must be on "High Performance"...not "Balanced".

          AMD graphics performance

            • Re: Automatic Underclocking to half frequency using latest Crimson Software (Windows 10)
              aseemdomaini

              I tried increasing the power limit after reading your reply, but it did not worked. From what I have observed, GPU is not getting low power as after I reset the Overdrive my games runs fine , CS-GO specifically and I do not see any frame drops or throttling.

              Also , under-clocking only happens during startup and only after 2-3 minutes of logging into windows. If i check overdrive setting right after start-up then they look fine but if I wait for few minutes and then check, I see the upper limits for GPU and Memory clocks beings set to Half of their original values.

               

              Not sure if its steam or CS-GO related.

               

              I have also played around with windows power settings but nothing worked for me. BIOS upgrade is something that I will try next. I also disabled ULPS .

               

              These are the some additional details about my Hardware:

               

              Processor Model     : AMD FX(tm)-6300 Six-Core Processor

              Logical cores        : 6

              CPUID                : AuthenticAMD family 15, model 2, stepping 0

              Display device       : AMD Radeon HD 7700 Series on Cape Verde GPU

              Display driver       : 9.14.10.01183, Crimson 16.3.2

               

              Crimson is slightly older as I was trying different versions, same problem with the latest also.