AnsweredAssumed Answered

Computer crashes after installing AMD drivers. help?

Question asked by razazo12 on Jun 4, 2016
Latest reply on Jun 6, 2016 by amdmatt

Well.. It seems to happen to me everytime I get a fresh clean install of my windows. It happened to me when i got my new computer. the computer is not even 1 years old..

First lets start with specs:

PSU: FSP HYPER 600W

Video Card: AMD R9 270x 2GB 5GDDR windforce 3x

Motherboard: Gigabyte B85M-D2V

Processor: Intel core i5-4460 CPU @ 3.20 GHz, 3201 MHz, 4 Core(s)

RAM: 8GB

OS: Windows 7 64 Bit.

 

The first problem I had was that randomly my screen would go "NO SIGNAL" and then my computer would go BSOD and I recieved an atikmpag.sys bsod. This is not longer i problem i don't know what fixed it but its gone.

Now the problem is that my screen just freezes(only mouse can move) and then screen goes "NO SIGNAL" again, turning to black while sound loop quickly in the background and just stays like that untill I force a restart. Sometimes it would even boot itself staight to the screen that asks me if i want to:

start compter normal, safe mode,\networking etc. - just skips the BIOS screen goes straight to this screen.

 

I uninstalled the AMD Drivers i'm currently running (16.5.3 crimson) and the computer works just fine. the moment i install the drivers the problem comes back.

 

PLEASE HELP.. i'm trying for 4 days straight.

I tried to: Uninstall drivers with DDU.

Updating windows to the latest.

downgrading AMD version.

it seems only uninstalling the driver works.. but how can i use my computer like that?

Computer only working in safe mode

 

UPDATES:

I reinstalled crimson 16.3.2. i can't even see the dekstop for more than 5 seconds. computer just crashes.

Outcomes