1 Reply Latest reply on Jun 3, 2016 6:45 AM by amdmatt

    MSI R9 380 GAMING 4GB still downclocking / stuttering temp fix

    polarbearking

      Basic build

      Fx8350 default to 4.4ghz (water cooled)

      Windows 7 64 home on ssd

      As rock 970 extreme 3 mobo

      16gb ram @ 1600mhz

      Full atx case with 9 fans

      MSI R9 380 4GB

      more hdds where programs are installed and files stored.

      2 monitors, 1 via hdmi (main) 1 via dvi (extended)

       

      About 1 month ago (on win 10 64bit home-clean install, no upgrade) my gpu started stuttering,  I did no driver updates, but there was win 10 updates like there are every 2 weeks. I thought one of the updates did it but like every one knows, you can't do anything about win 10 updates, so I tried rolling back amd gpu drivers, no luck. Due to other problems with 10 I decided to go back to win 7. Still gpu downclocking. Tried clockblocker, it lessened the frequency but did not stop. I tried every driver new and old for the R9 380 for win 7. Being a fairly new card there were only about 10 different ones, ran ddu for each fresh driver install, no luck (supposedly crimson 16.3 was the down clocking fix,  nope). I tried the suggested regedit, still present. Tried installing the games on my ssd and other hdds, not the hard drives.

      So the weird thing is what fixed it. I went to MSI site for their drivers, they have driver 15.15.1004 being the latest for this card on win 7 (I tried 15.15.1004 already via amd site with no luck). The msi download was its own zip file instead of a link to amd site to download. It was a zip install of amd 15.15.1004. This actually fixed the stuttering/downclocking. I ran furmark, played for 1 hour, all is well.

      So for some reason amd's 15.15.1004 driver is messed up compared to msi download of the same driver.

      So if you have this card and this problem, try their amd drivers instead of amd's site. I have not nor plan on going back to windows 10 so I do not know if this will fix it if your on 10, but it won't hurt to try. I am posting this in hope amd is made aware the downclocking is still a huge problem. I'm glad I was able to fix it, but shouldn't have to be stuck with old drivers due to amd failings. I know it has to with the power saving feature which is apparently forced. If I wanted power efficiency, I would go with intel/nvidia.

      To AMD:

              You have 3 months to implement an option to opt in for the power saving feature, but default must be off.... or my next 1100 builds (the avg # of pc builds I build for work yearly) will be full intel/nvidia components. The current button to turn it off is pretty to look to at, but does nothing. Due to this issue, all AMD gpu requests are being rejected at my company until this issue is fixed and all R series gpu have been removed from our site and shelves. (Tried telling the finance Mgr its not all the R cards, she said she does not care, we have to make our customers happy with fully functional PCs.)  She is not a tech person, but still a boss.