41 Replies Latest reply on Sep 7, 2016 12:54 AM by raz800

    Poor performance with 7970m vs previous 6970m

    raz800

      I'm assuming this would be a driver issue, but I recently upgraded my m18x gpu from amd 6970m to amd 7970m and across the board with games I play I am seeing lower fps with the same settings. I'm using the most recent driver Crimson 16.5.3 hotfix, but I also tried the previous Crimson 16.3.2 and have the same problem.  My setup is:

       

      m18x r1 alienware laptop

      windows 10 OS

      i7 2760qm cpu

      single amd 7970m gpu

      8gig ram

       

      My psu should definitely not be an issue, and I believe temps are fine.  From what I read the 7970m should blow away the 6970m so any suggestions to what the issue is here?  Thanks in advance.

        • Re: Poor performance with 7970m vs previous 6970m
          kingfish

          If you check in the Device Manager ...do you see any yellow marks?

          The reason I asked, is your Intel/AMD switchable graphics do not meet the requirements for Win10. The graphics solutions for any switchable/dual laptop graphics must both support the OS and work together. The Intel drivers do not support Win10. Your best bet is to revert to a supported OS.

          Laptops with switchable AMD/Intel graphics Windows 10 support

          • Re: Poor performance with 7970m vs previous 6970m
            raz800

            So I finally got Windows 7 back on my system and did all the updates.  I have installed the latest amd drivers again and now I am getting even worse framerates than with Windows 10.  There is a definite issue as my 6970m worked better in either OS.  Is the 7970m totally compatible?

            • Re: Poor performance with 7970m vs previous 6970m
              nospheratu

              The 7970M is compatible as many M18X R1 users are using them. Make sure in your BIOS you are in discrete graphics mode and the Intel integrated graphics is disabled.

               

              As a simple test I would suggest running a 3Dmark Firestrike benchmark to gauge your current performance level. The result should also provide you with temperature readings for your CPU and GPU to determine if everything is running within spec.

               

              A more detailed way of achieving this for your GPU would be to run GPU-Z with background logging enabled and play any game or run the 3Dmark Firestrike benchmark. The resulting log file will provide us with GPU voltage, clock and load values which we could analyse further to see where the problem lies.

              2 of 2 people found this helpful
                • Re: Poor performance with 7970m vs previous 6970m
                  raz800

                  So my integrated graphics have been disabled until I did the fresh install of Windows 7.  I am definitely in discrete graphics, however.  I downloaded some programs yesterday including GPU-Z, MSI Afterburner, and MSI Kombustor.  I noticed on GPU-Z and Afteburner that my core clock was set at 850MHz, but I was only reaching a max of 450MHz in game and during benchmark tests.  When I enabled unofficial overclocking, I set it to 851 and instantly it jumped to that, also if I set to 849 it will also achieve that, but going back to 850 drops to 450MHz again.  I have my power plan set to high performance for both battery and plugged in.  The highest temp I got during 3DMark was 79 celsius.  I have seen many people clocking the 7970m between 900-1000core and 1200-1500mem, but what is a safe temperature range?  I am going to do more tests and watch temperature once I have everything together.  Here are some shots of GPU-Z and Afterburner:

                   

                  GPUZ.PNG

                  Note that if I don't have MSI Afterburner clocked the Bus Interface in GPU-Z was showing PCI-E 3.0x16 @x8 1.1 even in game or using the render test.

                   

                  MSI overclock.PNG

                  MSI 850.PNG

                  MSI 849.PNG

                  You can see the max go to 450MHz when I set it to 850 from 851 and then jump back up when I drop to 849.

                   

                  Here are shots of my 3DMark at 850MHz(only reaching 450MHz) and then set to 851MHz in Afterburner:

                  Firestrike1.PNG

                  Firestrike2.PNG

                   

                  Any idea what the issue might be?

                    • Re: Poor performance with 7970m vs previous 6970m
                      nospheratu

                      Great post raz800 A lot of useful information there.

                       

                      Can you confirm your PSU is connected properly and recognized by the laptop? An easy way to determine this would be to check if your battery is being charged. If the center ID pin on your PSU connector isn't making proper contact the laptop will treat the PSU as a third party PSU and reduce it's power consumption which could be why we're seeing your card operate in low power 3D mode.

                       

                      I am running two CLEVO 7970M's in CrossFire at stock clocks of 800/1200 and my temps average around 70C-75C. On graphically intensive games were CrossFire scaling reaches >90% on each card (eg. Crysis 3) my temps can go up to around 85C. I would say 79C is a bit on the high side for a short 3Dmark run but not unacceptable. Your ambient temperatures and paste job could be playing a role here as well.

                       

                      Please check on your PSU so we can investigate further if need be.

                        • Re: Poor performance with 7970m vs previous 6970m
                          raz800

                          My psu is definitely connected and charging the battery.  It is the DA330PM111, which is 330W.  I would agree that for some reason the card won't increase power consumption unless I am using MSI Afterburner, but it is really strange that even then it cannot be set to exactly 850MHz or it only allows a max of 450MHz.  Funny that you mention my thermal paste job as it was pretty shotty and messy because I had my laptop apart and was troubleshooting between my 7970m and 6970m cards.  I cleaned it up and reapplied before I put my laptop together entirely so I would definitely expect lower temps, just haven't checked yet.  Thank you for your info and help!

                            • Re: Poor performance with 7970m vs previous 6970m
                              nospheratu

                              Yeah, it's definitely strange. There is something preventing the card from reaching proper 3D clocks we just have to figure it out. It could be some power setting that we have overlooked or it could be the combination of the card, it's vBIOS and the M18X.

                               

                              Regarding the thermal paste, since we have to apply the paste on a naked die with mobile GPU's the spread method is the only option. The most simple method to do this and achieve consistently good results is the "tape method". I use a slight variation of the method detailed here as I did a single drag of my card across the paste to minimize any air pockets. The link should help you understand the concept. Also make sure that your thermal pads on the vRAM aren't affecting your heatsinks contact with the GPU die. A trick I use is to shine my cellphones flash from the opposite side of the card after the heatsink is installed to make sure the heatsink is sitting flush with the metal square around the GPU die and no light shines through any gap.

                               

                              What are your idle temps on the card? Confirm all fans are running correctly by using a utility like HWinfo to read the fan sensors.

                               

                              Can you also confirm what card you purchased? As far as I know there are Dell, CLEVO and MSi 7970M cards available. Dell and CLEVO cards are the most common. An easy way to differentiate between them..

                              DELL cards - Blue PCB - Silver screw holes - AMD logo on the PCB

                              CLEVO cards - Blueish green PCB - Brown screw holes - May have capacitors that are uneven as they were hand soldered.

                              MSi cards - Green PCB

                               

                              I just noticed that your CPU scores in 3Dmark seem more or less in line with other 2760QM's on 3Dmarks website so it doesn't look as if the machine is in a low power state. That said, if you are running any sort of overclock on the CPU I would suggest disabling it for the time being.

                               

                              You mentioned that you were troubleshooting between the 6970M and the 7970M. When you installed the 6970M back into the machine did it also exhibit the same issue? I would suggest installing an older driver for now as the newer Crimson's have dropped support for non-GCN cards. This way you can swap between cards while troubleshooting and use the same drivers which should help rule out the driver somewhat.

                               

                              Another thing to try would be the power drain trick, if you have not done so already. Disconnect the PSU, Battery, CMOS Battery and then hold the Power button for down for 30 seconds. Then connect everything up again. Your BIOS will reset to it's default settings so make sure you are in discrete graphics mode again.

                               

                              Hopefully we get to the root of this soon so you can start enjoying the card

                              1 of 1 people found this helpful
                                • Re: Poor performance with 7970m vs previous 6970m
                                  kingfish

                                  I had a similar issue with a desktop computer when upgrading from a HD4870 to a HD6970. I was almost bald before I stumbled across this process, which fixed it for me > Uninstall Hidden Devices, Drivers, and Services

                                  1 of 1 people found this helpful
                                  • Re: Poor performance with 7970m vs previous 6970m
                                    raz800

                                    That is some great info on the thermal paste, thanks!

                                     

                                    Idle temps on the card are:

                                    -set to 800MHz in Afterburner(which makes it a constant 800MHz) = 58C

                                    -without Afterburner or the default 850MHz (ramps down idle from 450MHz to 300MHz) = 47C

                                     

                                    My card should be Dell, it is blue as you said and also says that in GPU-Z.  Not overclocking the CPU at all.  When I tried the 6970m there was no issue at all.  I didn't run any benchmarks with it, but it ran as well as it always did(which I would say is normal performance for that card).  That is useful info on the drivers as I kept having to install different ones for each card, wish I would have realized that.  I probably won't swap the cards out again, but do you think I should try a different driver with the 7970m?  I figured the newest should perform the best.

                                     

                                    I tried the power drain trick.  My computer gave me 5 beeps after I connected the AC cord again.  I manually shut down and turned on again, the computer restarted on its own before Windows and then booted normally.

                                     

                                    Could there be a UEFI issue?  I see the box checked in GPU-Z.  Is it worth messing with the vBios?  Should I be worried about bricking the card?

                                      • Re: Poor performance with 7970m vs previous 6970m
                                        nospheratu

                                        What are your ambient (room / weather) temperatures? Do you notice your fan noise increase and decrease or is it consistently the same speed?

                                         

                                        The "Subvendor: Dell" will always appear as GPU-Z read's your motherboard data to populate this field. I can understand it's misleading but this value will never change since you have an Alienware M18x (Dell). For example I am running CLEVO cards in my Alienware M17x R2 and GPU-Z reports the below.


                                         

                                        I know swapping cards is a bit of a chore but it would be better if you tested the 6970M like you did the 7970M so that we know for certain that it's attaining full 3D clocks. If for example we find that the 6970M is not reaching full 3D clocks we can immediately rule out the 7970M as the problem and focus on the laptop itself.

                                         

                                        I would suggest running the Catalyst 15.7.1 drivers until this is resolved. Make sure you use DDU for uninstalling your current drivers in safemode.

                                         

                                        Also make sure your laptop is updated to the latest motherboard BIOS which seems to be A05 according to Dell's website.

                                         

                                        The 7970M's vBIOS has the ability to work with legacy and UEFI so that shouldn't be a problem. GPU-Z is just reporting that the card is UEFI compatible. I don't think we should get to the vBIOS just yet. We need to know for certain what card you're running (most likely Dell from the vBIOS version) since different manufacturers cards behave differently due to how they implement their fan/temp sensors.

                                        1 of 1 people found this helpful
                                          • Re: Poor performance with 7970m vs previous 6970m
                                            raz800

                                            With the 7970m my idle temps today are:

                                            - set to 800MHz in Afterburner = 61C @ 23C room temp

                                            - default without Afterburner which should be 850MHz(shows 450MHz then drops to 300MHz) = 44C @ 23C room temp

                                            The fans are running correctly for my gpu and cpu as they ramp up when under load and then back down for idle after cooling. 

                                             

                                            I understand what you are saying for the Subvendor section in GPU-Z, that makes sense.  I am 100% sure my card is the Dell version.  It looks identical to this:

                                            Dell 7970m.jpg

                                            I uninstalled my amd drivers using DDU as I always do, and ran CCleaner after reboot, shutdown and swapped in the 6970m.  I installed the 15.7.1 drivers and restarted.  I opened GPU-Z and ran the render test for about 2 seconds then my computer crashed.  I couldn't load windows with that card in anymore so I have no idea if I wrecked it or what happened.  I took the card out, uninstalled the drivers again, put my 2nd 6970m in (as my m18x came with two in crossfire).  Installed the driver again and no issues this time.  I will test my other card again so see if it is alright.  I ran 3DMark and here is what I got:

                                            3DMark 6970m.PNG

                                            Seems to be a decent/normal score comparing other tests with the 6970m.  Here is what GPU-Z looked like:

                                            GPU-Z 6970m.PNGGPU-Z 6970m sensor.PNG

                                            The card is properly changing its clock when under load to idle.  It reaches a max of 715MHz under load, and as you can see drops to 100MHz idle.  Temps were about 78C under load @ 23C room temp and dropped to around 50C idle(not ideal paste job here).

                                             

                                            I am running the A05 bios for my motherboard already.

                                              • Re: Poor performance with 7970m vs previous 6970m
                                                kingfish

                                                Did you raise the Power Limit?

                                                • Re: Poor performance with 7970m vs previous 6970m
                                                  nospheratu

                                                  Sorry to hear about your other card, hopefully it was just a bad install and it's actually fine. From the specs it looks like it's a 6990M and not a 6970M. Good news is that we know for certain now that the 7970M is the problem.

                                                   

                                                  That is definitely a Dell card so we can start experimenting with different vBIOS versions. For now though, download GPUshark and run it. It will display the current performance state of the GPU. From the View menu select "Detailed mode" and post a screen print here. We just want to see if the vBIOS you're currently running was modified for low voltage. I just noticed that If I resize the GPUshark window my current pstate jumps to full 3D clocks. You can try the same to see if the card is still still switching to low power 3D.

                                                  1 of 1 people found this helpful
                                                    • Re: Poor performance with 7970m vs previous 6970m
                                                      raz800

                                                      Sorry for taking so long for reply, I have had quite the adventure trying to get my 7970m back in and working.  After taking out my 6990m(thank you for realize that my card is 6990m not 6970m as I guess I have just never checked the specs.  It always shows 6900m series for these cards.) I put the 7970m in and got everything together enough to start up.  My screen stayed black and was giving me 8 beeps, which is a gpu issue in the m18x.  I tried every combination of taking the card out and adjusting to make sure it was seated properly etc.  Removing it completely allowed the computer to post with my intel integrated graphics.  I installed the card again then unplugged the ac adapter and held the power button for 30 sec then held down the fn+del while plugging the adapter in, keeping them pressed I then pressed and held the power button until I got the crazy beeps.  After it tried to post it would still give me the 8 beep codes so finally I put the 6990m back in and it loaded fine.  I ran DDU just to be entirely sure the old drivers were properly removed and shut it down after.  Now came the fun part.  I wasn't careful enough with the power cable that goes from the power button to the MB and I ripped out some of the wires on the plug that connects to the MB.  After about an hour of using my surgeon skills I managed to get the 3 ripped wires each in the holes and pinned them temporarily.  I then got a thin layer of glue so they are secure and it is working fine... whew.  Lesson learned there. 

                                                       

                                                      I was finally able to get my laptop to post with the 7970m so I guess the drivers didn't uninstall properly or something there.  I installed the newest drivers from amd, crimson 16.5.3 hotfix and when I restarted everything looked fine.  I opened GPU Shark, here is what I found:

                                                       

                                                      GPU Shark.PNG

                                                       

                                                      I decided to run a game just to make sure nothing changed.  It seemed that the card was working properly so tabbed out to check and low and behold:

                                                       

                                                      GPU Shark 2.PNG

                                                      The card properly ramped into the 2nd Pstate and is working perfect!  There had to be something off either in my drivers or MB bios.  Good news is that everything seems great now and the card ramps back down to 300MHz when idle.  Thank you kingfish and nospheratu for all your help, you have been great!

                                                        • Re: Poor performance with 7970m vs previous 6970m
                                                          kingfish

                                                          That was quite the journey!

                                                          • Re: Poor performance with 7970m vs previous 6970m
                                                            nospheratu

                                                            That's great news!! A bit of a tricky one that. My money would be on the motherboard's BIOS though. The Insyde BIOS is known to be a bit sticky with clearing old values hence the power drain trick.

                                                             

                                                            I'm just glad you were able to resolve the problem and can now enjoy your games It's just a bit sad that some of your components were damaged along the way.

                                                              • Re: Poor performance with 7970m vs previous 6970m
                                                                raz800

                                                                I'm still having intermittent issues with the 7970m.  Early this week it wouldn't post and gave me 8 beeps.  I had to take the card out again and then my laptop booted fine into integrated graphics.  I uninstalled the AMD drivers and removed every AMD/ATI folder off my computer that I could find in C: and in the registry using regedit in the run command.  I tried the card again and the computer posted fine.  I also got my 6990m that stop working to post again.  I put the 7970m in and reinstalled AMD drivers.  The card worked perfectly for the rest of the week until last night.  Now it won't post and is giving me 8 beeps again.  I also noticed that my RTC clock wouldn't keep time when the computer was off, it would show the time from when the computer was last on the next time I booted it.  I have everything set to synchronize with internet server, and no change different servers.  The time would sync when I forced it and keep time correctly as long as the computer was on.  I have 2 CMOS batteries and tested them, both working.  I messed with the wires and plug that connect to the MB to make sure the connection was good.  Strange thing is that the last time my computer booted up last night it was keeping time correctly even when off.  I'm not sure that this is an issue with the card, but possibly something with my bios or the MB, especially since my other 6990m started working again.  I just replaced the MB a couple months ago so I would hope that is not the issue.

                                                                  • Re: Poor performance with 7970m vs previous 6970m
                                                                    nospheratu

                                                                    The intermittent issue with your RTC is a bit concerning and is a symptom of an underlying issue which could be the root of the problem.

                                                                     

                                                                    I would suggest re-flashing your motherboard BIOS A05 at this point, if you have not already done so.

                                                                      • Re: Poor performance with 7970m vs previous 6970m
                                                                        raz800

                                                                        Hey there, just wanted to post a follow-up.  I have found a working 7970m and have had no issues with it in my m18x r1.  However, I have gone through four 7970m total now and the other 3 have not worked.  The card that works was sent as a replacement to the original that I bought.  The vbios in this card are 15.017 and the three cards that haven't worked are all 15.022.  Is there any known issues with the newer vbios on the Dell cards and the m18xr1?  I found this very strange and it could just be coincidence.  One of the other cards did post besides the first one that worked intermittently, but there were red vertical lines so I assumed that it was just going bad and it wouldn't post again after that.  It also never fully booted into windows as the screen would stay black just before it made it to the login screen.  I ideally wanted to run two of these in crossfire, but I'm just sticking with the one that works as it is still a great upgrade.  There is just a feeling of dissatisfaction with not being able to make the build I originally wanted.

                                                                          • Re: Poor performance with 7970m vs previous 6970m
                                                                            kingfish

                                                                            I personally have never had any luck changing video graphics in a laptop. Always a problem crops up. I am assuming you have disabled the Intel graphics in the bios and set the discrete card as primary? You have looked for a bios update? Is your computer power plan set to "Performance"? In Overdrive do you have a 'Power Limit' scale...? If so, what % do you have it set at?

                                                                            Look in the Device Manager...do you see any yellow marks?

                                                                              • Re: Poor performance with 7970m vs previous 6970m
                                                                                kingfish

                                                                                Re-reading your laptop specs...I see a problem. You have switchable graphics...Intel/AMD. The Intel graphics are not supported in Windows10. There are no drivers for it. Microsoft supplies a very basic driver so you can surf the web...but it does not work with a switchable (or Enduro) configuration. AMD drivers will not work with it. Your only hope is that you can disable the integrated graphics in the BIOS...not the Device Manager. Or revert to Win7.

                                                                                  • Re: Poor performance with 7970m vs previous 6970m
                                                                                    raz800

                                                                                    The m18x does not have switchable graphics to my knowledge.  When there is

                                                                                    a gpu in the primary slot discreet takes over fully, at least in my system

                                                                                    it does.  In device manager only the 7970m shows.  The 7970m I have with

                                                                                    15.017 bios works perfectly, but I was just curious why the 3 newer 7970m I

                                                                                    tried with 15.022 bios didn't work.  I have Windows 7 again now as I

                                                                                    reinstalled it when I was troubleshooting the first 7970m I got.

                                                                                      • Re: Poor performance with 7970m vs previous 6970m
                                                                                        nospheratu

                                                                                        Sorry to hear you're having problem's with the new upgrade. It's interesting to know that you was sent the 15.017 vBIOS version for the replacement and it works. It could be that the seller knows something about the versioning and the M18X R1 that we aren't aware of.

                                                                                         

                                                                                        1. Where did you purchase these cards?

                                                                                        2. Does your newest card have a date or time stamp at the back of the card? The reason I ask is I know there were issues flashing the 022 card's when they first released, this has since been resolved.

                                                                                         

                                                                                        One possible option to try is to dump the 017 vBIOS from the primary card and flash it to the secondary card. It is always recommended to use the same vBIOS on both cards although I have mines on different versions at times. Please let me know if you want to try this and I will provide you with the instructions. As with flashing the firmware of any device there is a risk of bricking.

                                                                                         

                                                                                        3. Are you installing the 022 card in the secondary slot?

                                                                                         

                                                                                        I would suggest doing some research on notebookreview.com's forums if you have not already done so. There is a wealth of knowledge for laptop specific upgrades and troubleshooting. Search in the  Alienware->M18X sub-forum for 7970M crossfire troubleshooting.

                                                                                          • Re: Poor performance with 7970m vs previous 6970m
                                                                                            raz800

                                                                                            The original I bought was from ETECCOMPUTER on Amazon.  That card was the

                                                                                            one I originally posted on here about.  That card would work

                                                                                            intermittently, but would randomly not post and cause a beep code.  I sent

                                                                                            that back and the replacement they sent me is the one that works great with

                                                                                            15.017 bios.  After that I bought a card also on Amazon from a company in

                                                                                            China.  They say that they cards are fully tested, but I can't seem to get

                                                                                            them to work.  The two other cards I have in my possession still are both

                                                                                            15.022, but I don't see any sort of time or date stamp on them.  I tried

                                                                                            both cards in the primary slot first. One of these cards acts like it is

                                                                                            working, but the screen stays black and it doesn't give any beep code(we

                                                                                            will call this card A).  The other one booted the first time I tried it,

                                                                                            but was showing red vertical lines similar to the first card that I got

                                                                                            from ETECCOMPUTER (card B).  It never made it fully to the login screen and

                                                                                            stopped booting after that.  I put my working card in the primary and put

                                                                                            card B in the secondary and connected the crossfire cable and I could boot

                                                                                            into windows.  The card B is showing in device manager, but it has a yellow

                                                                                            "!" and says code12 cannot find enough resources to power it.  I have the

                                                                                            330w adapter for my m18xr1 and was running crossfire with 2 6990m before

                                                                                            this so I don't think there is a power issue.  If I put card A in the

                                                                                            secondary slot with my working card in the primary the screen stays black

                                                                                            and no beep code is given.  I have done quite a bit of researching, but I

                                                                                            can't find anything about consistent issues with the 15.022 cards, and I

                                                                                            thought the card should at least work in the primary slot alone.  I would

                                                                                            be willing to try and flash one of the cards with the bios of my working

                                                                                            one.  Thanks for the help!

                                                                                             

                                                                                            On Sun, Aug 28, 2016 at 12:55 AM, nospheratu <amd-external@jiveon.com>

                                                                                              • Re: Poor performance with 7970m vs previous 6970m
                                                                                                nospheratu

                                                                                                Okay first we have to get the tools we need for the flashing. You will have to do this by booting into DOS, do not even think about flashing within Windows in a command prompt as the convenience is just not worth it, the risk is of bricking your card is high. There are plenty of guides on how to create a bootable drive with DOS online using a thumb/flash drive so I won't get into that bit. I would suggest using Rufus.

                                                                                                 

                                                                                                Download ATIFlash from here.

                                                                                                Extract atiflash.exe to the root of your bootable DOS USB drive.

                                                                                                Reboot your laptop and boot from your USB drive into DOS.

                                                                                                 

                                                                                                The first command to use is to backup your vBIOS for a card. The number in the command denotes the primary or secondary card, 0 for primary and 1 for secondary. You could run the command, "atiflash -i" beforehand to display the number of detected GPU's and their information. Use the below command to back up the vBIOS for the primary card.

                                                                                                 

                                                                                                atiflash -s 0 original.rom

                                                                                                 

                                                                                                The above command will save the vBIOS from the primary card (0) to a file called "original.rom" on the usb drive. Do the same for the secondary card, ie.

                                                                                                 

                                                                                                atiflash -s 1  new.rom

                                                                                                 

                                                                                                You can name the files anything you like just make sure that you don't exceed 8 characters and include the .rom extension so you know these are vBIOS files. I normally use the version of the vBIOS in the name.

                                                                                                 

                                                                                                Once you have backed up the vBIOS from all your cards you can flash the card with the newer vBIOS with the 017 vBIOS with the below command. This is assuming you have the 017 vBIOS card in the primary slot.

                                                                                                 

                                                                                                atiflash -p 1 original.rom

                                                                                                 

                                                                                                The above command will program the original.rom vBIOS file you backed up to the secondary(1) card.

                                                                                                 

                                                                                                Make sure you are connected via AC and your battery is charged. You don't want your machine to shutdown during the flashing process as it will render your card useless if the flash does not complete.

                                                                                                 

                                                                                                Disclaimer: Flash at your own risk, you are responsible for your system and the changes you make on it.

                                                                                                 

                                                                                                That said, I have flashed my card's multiple times experimenting with different vBIOS versions without experiencing any issues. If you have any questions or are unsure about any of the instructions please let me know.

                                                                                                 

                                                                                                Best of luck, I hope this resolves your issue