9 Replies Latest reply on May 30, 2016 4:28 AM by ognjenp

    Unable to install drivers r9 390

    ognjenp

      Ever since I got my msi r9 390 a couple of days ago I've been battling driver issues. At first I tried installing drivers from the provided disc, but that proved impossible as the installation would not actually install anything, just finish itself as if everything were fine (yet nothing was installed). After a couple of hours of uninstalling, installing, downloading rebooting and praying I managed to SOMEHOW install drivers and my card started working, sort-of. Now, the problem I have is this

       

      1. at first the installer would only show peripheral programs and no drivers to install
      2. once I managed to make it give me the option of selecting the graphic drivers in the installer, it would go to 2%, hang there for 15 seconds then proceed to finish the installation in its entirety
      3. nothing was actually installed, other than the sound drivers
      4. catalyst manager or any other provided driver manager from AMD would simply refuse to install
      5. uninstalling drivers wouldn't fix the issue, in fact I got a bluescreen with an 0x004c error once the uninstaller got to the display drivers

       

       

       

      Here's my system information

      Radeon MSI R9 390

      Windows 7 Ultimate 64bit

      Crimson 16.5.3, I also tried the 15.11 version

      Asus VW221D

      Gigabyte Z77X

      Intel i5 3570k

      16GB of RAM

      For the love of God, please help me

       

       

      P.S. Also, every piece of software is showing me I have 4GB of gpu memory when I have 8.

      P.P.S. It appears that I have trouble with the installers themselves, since I uninstalled the drivers several times using Display Driver Uninstaller, every time I would attempt installation the Radeon installers would simply not display any display driver options, just the additional programs

      Imgur: The most awesome images on the Internet and Imgur: The most awesome images on the Internet  

      http://imgur.com/de9ihol are what I get every time I try to install.