8 Replies Latest reply on May 25, 2016 3:23 PM by slappingham

    Battleborn and the 8350 fx

    slappingham

      Struggled to navigate this website and this be the first place I've found where I can actually write something.

       

      As is the common consensus among users of the amd 8350 and various amd g/cards across many forums relative to Battleborn, we're having a pretty crappy time with that game. Performance is terrible and can't be adjusted by lowering the graphics which happens with around 50% of the new releases i buy.

       

      I don't care about fancy graphics. I care about fps. Not being able to adjust graphics to increase fps is torture if I'm honest.

       

      With battleborn, it only uses two cores of the 8350 where as far as I'm aware, the unreal engine 3 is capable of using 4?? That might not help.

       

      Despite this, performance is what it is, jumping from 120fps to as low as 25fps with an average of 40fps on lowest settings  (which is below my monitors refresh rate). Forums are rife with this concern from people with many hardware configs, however it seems *all* AMD users are to some degree.

       

      Ram usage doesn't exceed 3.5gb which is fine. One odd thing to note is that the cpu and gpu gets used more in the main menu and in lobbies than in the actual game. What the...?

      Doom and overwatch seem to be high on your agenda for updates. Can battleborn get some love? Either that or once again I've wasted £40. Again lol. (Wouldn't be surprised of physx had a hands in this though, despite being turned off with maxparticledensity = 100)

       

      Please look in to this?

       

      P.S. I'd settle for a detailed explanation of why we often have this issue. Devs will never respond to AMD queries.

        • Re: Battleborn and the 8350 fx
          brucer

          What gpu are you using?

           

          The first thing you need to do with the fx8350 is park your cores.

            • Re: Battleborn and the 8350 fx
              slappingham

              I'm assuming you mean *unpark*?

              That's one of the first things when i installed win 10.

               

              Windows is in high/perf for good measure too. My mobo has all latest drivers including bios and I'm running the very latest Crimson.

               

              (Tried overwatch for the first time last night. That runs at no less than 80 fps maxed out so from that i suppose we could assume my hardware is in good working order)

              Thanks for the reply.

               

              My specs are:

              R9 290x 4gb

              Fx x8 core 8350 4.7ghz (watercooled)

              8gb corsair vengeance 1666mhz

              X2 samsung 840 pro 250gb ssd

              Asus M5a99x evo r2.0 motherboard

              Aoc g2770pf freesync monitor

              Corsair 750w 50A single rail psu

                • Re: Battleborn and the 8350 fx
                  brucer

                  no, I meant park the cores.. You park the cores, as in not to let them throttle or downclock.

                    • Re: Battleborn and the 8350 fx
                      brucer

                      Something else, do you have a frame rate target control set?  I see you have a freesync capable monitor, that might be where your having issues.. It might be freesync thats causing it.  Thats where I would start looking into.. I've read freesync is having a lot of issues lately.

                      1 of 1 people found this helpful
                        • Re: Battleborn and the 8350 fx
                          slappingham

                          That's really interesting brucer. In Crimson I have no target fps anywhere  in game, the fps is set to unlimited.

                          Also its the first time I've ever had it suggested that the cores should be parked. Naturally I've set it so that the engine controls what cores are used. I've been in the habit of making sure cores are unparked since win 7 to the benefit of many programs.

                          Any further advice on that?

                          Really grateful thus far!

                          Oh I've tried disabling freesync btw... made no difference. I've tried the game with vsync on again, its still very bad.

                            • Re: Battleborn and the 8350 fx
                              brucer

                              for my Fury with the Crimson drivers the Framerate Target control is in Gaming/Global Settings.

                               

                               

                              Are you using a display port cable? If not you should be..

                               

                              about the parking, I'm running an fx8350 in my old gaming rig, its parked at 4.2ghz (air cooled with 212evo) and has been since I built it 4 or 5 yrs ago, its a strong running computer for its age.

                               

                               

                               

                              My current machine is an overclocked I5-6600k@4.5ghz (air cooled with cryorig h5u) with a Sapphire Nitro Fury overclocked to 1080mhz for now..

                              Currently I'm running a Crossover 32s  freesync monitor, its overclocked to 75hz, freesync enabled and framerate target control set at 74fps.. I'm just testing the monitor overclock, it was at 60hz normally and my frame rate target control was at 59fps. I read an article about my monitor and found it was overclockable to 75hz, and I'm finding out it is.

                              1 of 1 people found this helpful
                              • Re: Battleborn and the 8350 fx
                                kingfish

                                You are correct. You want to unpark the cores. 100% means no core is parked.

                                Screenshot_3.png

                                1 of 1 people found this helpful
                      • Re: Battleborn and the 8350 fx
                        slappingham

                        Anyway... my cores are unparked. All 8 cores can be used when the program requires it. The fact that battleborn uses 2 cores is down to the devs at gearbox tbh.

                        I am using a DisplayPort cable. Like I say, the monitor is 144hz and to correct myself about the overwatch performance earlier (i.e. 80fps) it actually doesn't dip below 120fps (ran rivatuner on it earlier).

                        The problem is either 1: a driver issue since AMD haven't released anything for it yet, despite being really active with their updates lately or 2: gearbox have given anyone with AMD processors (and some graphics cards) the middle finger. Honestly, it isn't playable for me. It runs 100% better on ps4. Its much the same situation for many, many other fans of the game using an AMD processor. Thing is, some folk with an intel processor and amd g/card have performance issues too, and the performance is so bad that I genuinely think that both AMD g/cards and processors are involved in the issue in combination.

                         

                        I think it needs a driver update for the game, and that this would *help* a bit, but gearbox need to address their obvious lack of careface for AMD processors. Its just annoying that an amd athlon x4 is listed in their recommended specs. Its misleading.

                        Bought the boxed version so couldn't a refund like you can on steam.