13 Replies Latest reply on Jul 30, 2016 2:09 PM by getlogan

    R9 380 Sapphire still causing crashes.

    mimz

      Hello,

       

      I've got an Sapphire R9 380 Dual-X 4Go DDR5 since some months, and I keep crashing with it, even if I use all the drivers we can find. I tried beta pilots, I tried to downgrade it, and I still get those crashes :

       

      - Black screen with "no signal" but computer keeps working. Have to restart manually.

      - Game freezing and I can leave thanks to ctrl/alt/supp. (I'm french, so french keyboard)

      - Computer totally freezing, have to restart it manually.

       

      I tried everything, even CHLDSK on my /C disk, checked the RAM, updated everything, underclocked the card, but I'm still having random crashes on every games, instead of Arma 3. (using CPU a lot) Games are : Battlefield Bad company 2 (can't finish a game without freezing), Battlefield 3, Verdun, Crysis 1/2/3, Fallout 4 (lot of crashes).

       

      Specs : Windows 10 64 bits, 8Go RAM DDR3, i5 3570K 3.4Ghz and Sapphire R9 380 Dual-X.

       

      I hope you will be able to help me or answering me that you know this and that you are working on it.

       

      Thanks for answer.

        • Re: R9 380 Sapphire still causing crashes.
          mimz

          One more freeze after a game on Verdun.

           

          And I've got the lastest drivers. Seriously, I'm getting angry now. Tried everything, un-installed-installed drivers/updates a lot of times, and still freezing.

          • Re: R9 380 Sapphire still causing crashes.
            mwnn

            Try reverting back to Catalyst 15.11.1

            Most people report that as a successful workaround.

            I've been through every Crimson version since their introduction with this problem.

             

            The issue is known now and should get fixed eventually - especially if people keep reporting it.

            I only wish I knew what's so different between Crimson and Catalyst which induces this behaviour - as nothing is changing hardware wise.

             

            Due to the stupid nature of Windows 10 it'll probably try to update your drivers automatically - we're not allowed to manage our own PC's you see...

            Unless your using a Pro or Enterprise edition (with some Group Policy changes) that could be an issue!

            I hope Microsoft make driver installation optional with Redstone.

            • Re: R9 380 Sapphire still causing crashes.
              mimz

              The crash seems like to be all the times this one : "Kmode exception_not_handled". I've found this thanks to "whocrashed". I tried to fix this many times, but impossible.

               

              I cleaned up the register, but I already did that and I was still crashing. Hope a driver fix for it.

              • Re: R9 380 Sapphire still causing crashes.
                mimz

                Any info on it ?

                 

                Reported the problem on the feedback.

                • Re: R9 380 Sapphire still causing crashes.
                  getlogan

                  When playing the System Shock demo for a few minutes the monitor will lose signal and display a black screen. A stuttering sound can be heard in the background on loop and the only way to recover from this crash is a hard reset of the computer. Upon restarting the computer and checking event viewer a log of the crash can be seen.

                   

                  EventID: 4101

                  Source: Display

                  Display driver amdkmdap stopped responding and has successfully recovered.

                   

                  I used to get the black screen crash on many other directx11 games (never had it on directx9 games), such as GTA5, Rainbow Six Siege, Satellite Reign, Unreal Tournament (the new one). However ever since a new driver released around April, at least for me, crashes in those games seem to be fixed as I have never encountered them again. System Shock is currently the only game I know of that still suffers from the same problem. I also get the same black screen issue with the Dolphin 5.0 emulator running with DX12 renderer and when playing movies in Media Player Classic using the MadVR renderer. Also graphics settings, resolution, windowed or fullscreen, refresh rate, FreeSync, tesselation, monitor, cable and port type, etc, does not matter as different combinations do not resolve the issue. Problem is a driver issue as it has been fixed in the past for other games.

                   

                  My specs:

                  Core i7 6700k (stock, never been overclocked)

                  Kingston HyperX Fury 16GB DDR4 (2x8GB)

                  Asus Maximus VIII Hero (BIOS 1701, current latest)

                  Seasonic XP-860 Platinum 860W Power Supply V2

                  Sapphire Radeon R9 380 Nitro Dual-X 4GB (stock, never been overclocked)

                  using Crimson 16.7.2 WHQL (shows as 16.7.3 in Radeon Settings Overview, installed after using DDU 16.1.0.1 in safe mode, Gaming Evolved NOT installed)

                  Windows 10 Home 64-bit

                   

                  Monitor (single monitor tested individually, crashes occur on either):

                  Benq XL2730Z using DisplayPort (2560x1440, 144hz, FreeSync)

                  Benq V2400W using DVI (1920x1200, 60hz, non-FreeSync)

                  1 of 1 people found this helpful
                  • Re: R9 380 Sapphire still causing crashes.
                    getlogan

                    Crimson driver 16.7.3 is an improvement for me.

                     

                    The System Shock demo still crashes. However, instead of getting the usual no signal black screen crash, now the game just crashes and I can continue using Windows without a hard reset.

                     

                    Same thing for Media Player Classic with madVR renderer. I still get a crash, but now I am able to alt-f4 to close the crashed Media Player Classic and continue using windows without a hard reset.

                     

                    Dolphin 5.0 emulator now seems to work without crashing using the DX12 renderer.

                     

                    Not sure if the crashes are a problem with the applications or display drivers, but I'm glad now the crashes don't stall the entire system.