3 Replies Latest reply on Jun 13, 2016 3:26 AM by amdmatt

    Drivers won't properly install,16.5.2.1 issues?

    bxr8

      Hello, so starting in the early am of 5/16 I was unable to play any  games on my pc. they would open, run for a bit, then crash after about a minute of gameplay regardless of what game I  would play. I then made sure the latest gpu drivers were installed but this did nothing, I also noticed that most of the options under "radeon additional settings" were missing (photo attached). I read AMD Radeon Software Crimson Edition 16.5.2.1 that said  that this was a known issue so i uninstalled all radeon drivers and apps. When i went to reinstall them I was prompted with an error saying  they were not successfully installed (error report attached). I repeated the uninstall/ install process but this time disabled my anti-virus, with the same issue occurring. I tried to uninstall a 3rd time but this time my screen went blank and I was unable to get a signal from my pc and was forced to shut down with no monitor signal upon reboot . I then took out one of my graphics cards and was able to get a signal with one of them, but I am not able to get any signal from my pc from the other. I once again installed the latest drivers but the same problem persists and now I get occasional flickering white or green pixels on dark backgrounds and occasionally my signal will cut out for a second. Is there anything else I can do to get my radeon settings back, and to be able to play games, and not have my screan flicker-out on me? Thanks!

       

      Hardware

      • Graphics Card
        • Two,  Asus AMD R9 270X 4gb memory each
      • Operating System
        • Windows 10 64bit
      • Driver version installed
        • Radeon Software Crimson Edition 16.5.2.1
      • Display Devices
        • Samsung T27B350ND 27" 1080p LED-LCD TV - 16:9 - HDTV 1080p connected with HDMI
      • Motherboard
        • Asus M5A97 R2.0
      • CPU
        • AMD FX8350
      • Power Supply Unit  Make, Model & Wattage
        • E.g. Thermaltake SMARTM7 750W
      • RAM
        • 16GB
        • Re: Drivers won't properly install,16.5.2.1 issues?
          amdmatt

          Please try the steps below to see if it resolves the issue.

           

          1. Run the Windows self check tool to check scan and automatically repair any corrupt files found in Windows. There is a guide on how to do it here.  What you need to do is run an elevated command prompt (elevated means run it as administrator) and type SFC /SCANNOW. This will generate a statement indicating if errors were found the Operating system and if they were fixable.

           

          2. Make sure you have installed Microsfot NetFramework and Visual C++ 2013. These should be installed already, but they can become damaged, need repairing or reinstalling.

           

          3. Update Windows. Install all available critical, recommended and optional updates. Often Netframework and Visual C are included in the recommended or optional updates Windows provides. Windows should always be fully up to date before installing our drivers!

           

          4. Use DDU to sweep the system of AMD drivers.

           

          5. Install the latest Crimson 16.5.2.1 drivers once the above is completed.