20 Replies Latest reply on May 30, 2016 12:51 AM by kotamaku

    AMD R9 390 can't run deadspace and deus ex human revolution.

    kotamaku

      So I have been trying everything I could to try and get these games to run but nothing seems to work. These two games I own don't seem to wanna run no matter what I do. Dead space 1 and 2 either crashes on start up or won't even launch and deus ex just won't open. My computer is more than able to handle these games and they worked fine on my old machine I no longer have, I am asking what am I suppose to do then. I used to have a nvidia card but got this amd one. I am starting to regret it as it seems like games I loved that worked well with nvidia don't wanna work for my amd one. I tried asking for support on EA's forums for dead space and so far they believe it is the crimson drivers causing the issues and tried to have me downgrade. Let's just say that it didn't work and it caused more of a headach than it was worth.

       

      So here I am asking here to see what can I do to fix my problem, what is causing it? WHAT CAN I DO TO FIX IT!? Attaching dxdiag txt