15 Replies Latest reply on May 23, 2016 11:11 AM by kingfish

    Blue Screen Of Death THREAD_STUCK_IN_DEVICE_DRIVER

    travis_daily

      About a month ago, I updated by driver version, and blue screened a few hours later. I rolled my driver back to "15.300.1025.1001" using the Device Manger. I tried again 2 days ago and got a blue screen yesterday: THREAD_STUCK_IN_DEVICE_DRIVER.

       

      You have multiple threads with this error code, but none of their advice worked, and I can't roll back to 15.300 anymore. Both 16.3.2 and 16.5.1 give this error code multiple times in a few hours.

      To be obtuse, none of these options worked:

       

      BIOS is up to date.

       

      I'm currently running on Microsoft's Basic Display Adapter since this driver won't work.

      Edit: Found a package with 15.30.1025.1001.

       

      Reference thread:THREAD_STUCK_IN_DEVICE_DRIVER

       

      This is my build: Intel Core i5-4690K, Gigabyte Radeon R9 290X, NZXT Source 220 - Compy 386 - Travis_daily's Saved Part List - PCPartPicke…

      Windows 10 64 bit.

       

      To be obtuse again:

      R9 290X

      Desktop

      Windows 10 64 bit

      Microsoft's Basic Display Adapter since both 16.3.2 and 16.5.1 crash my system. 15.30.1025.1001.

      "Dell S2240M 60Hz 21.5" Monitor"

      "Dell S2240M 60Hz 21.5" Monitor"

      "Asus Z97-A ATX LGA1150 Motherboard"

      i5-4690K 3.5GHz

      Corsair RM 750W 80+ Gold Certified Fully-Modular ATX Power Supply

      16GB