0 Replies Latest reply on May 8, 2016 6:22 PM by derschniffles

    Problems with r9 380 crossfire

    derschniffles

      Hey everyone, I have had nothing but problems with 2x Gigabyte R9 380 4gb card's and could use some help.

      I get black screens that go to "no signal" all the time. And its only when crossfire is enabled and specific games. I can get into the game, but when I go to load a save game it will load for a couple seconds and then, black screen with 'no signal.' Sometimes it will give me a driver has crashed and recovered message but most of the time it just goes to 'no signal.' Alan Wake used to do it but recently seems to load, Path of Exile happens 3 out of 4 times, same with Dirty Bomb, Ryse Son of Rome lets me play for about 10-15 seconds before it does it, Aliens Colonial Marines. I understand that a game like Path of Exile wont have a profile, but disabling it in the game profile does absolutely nothing, so I have to remember to completely disable crossfire to play any of the games I listed above. So even disabling crossfire in Path of Exile or any of the games that give me 'no signal', I still get 'no signal'. Crossfire has to be COMPLETELY disabled. Its broken.

       

      Other games just perform like utter crap. The witcher 3 is a mess, so is Need for Speed (2015), Batman Arkham Origins. It works without crashing but its unplayable. Others on forums claim to have it working no problem, but not my 380's.

       

      And then some games just perform fantastic with zero issues, like Farcry 3, BF4, Crysis 3.

       

      To sum up the issue, select games get a black screen which then goes to 'no signal' resulting in manual restart. Most other games just perform horribly with bad stuttering, crappy framerate with no fix. Select games run perfectly. Which so far has been about 4-5 games out of about 20. Those are terrible odds that what I paid for will actually work. Also considering that some of those games have crossfire profiles and I still cant use it...

       

      Things I have tried-

       

      I have tried every Windows 10 driver possible, tried different profiles for each game, tried AFR, AFR friendly, Optimize 1x1...Does not matter what I set it to, same issues.

      I have formatted twice

      Updated mobo bios

      Checked for new bios for video card and even called to ask about the latest version, both cards have latest F51 bios

      memtest86 checked out

      bought another psu just to test - not that

      rma'd video cards- same thing

      ran the hdmi straight to the tv, bypassing my AVR

      tried a different hdmi cable

      ran with no overclocking, cpu and gpu

      disabled all overlays, msi AB, RTSS, Steam, Origin

       

      Im sure I am forgetting some other things I have tried, ive been at it for a couple months now. I put a ticket in to AMD and got a response that "those games dont work with crossfire, turn it off." If a game has a profile for it, I expect to at least be able to load into the game to see if the scaling is worth it, but I cant even do that.

       

      Specs-

      MSI z170a Gaming M3

      i5 6600k @ 4.5ghz

      16gb Corsair Vengeance DDR4 3200mhz

      2x Gigabyte R9 380

      480gb SSD

      Corsair 850w psu