1 Reply Latest reply on May 5, 2016 5:10 AM by amdmatt

    AMD FirePro S9150 driver install Failed dependencies

    razor

      Trying to install driver for AMD FirePro S9150 on a Dell PowerEdge R730 running CentOS release 6.6. I

       

      have created the package for it but when I try to install I get failed dependencies:

       

      rpm -Uh --force fglrx64_p_i_c-15.201.2401-1.x86_64.rpm

      error: Failed dependencies:

              compat-libstdc++-33 is needed by fglrx64_p_i_c-15.201.2401-1.x86_64

              libX11.so.6 is needed by fglrx64_p_i_c-15.201.2401-1.x86_64

              libXext.so.6 is needed by fglrx64_p_i_c-15.201.2401-1.x86_64

              libgcc_s.so.1 is needed by fglrx64_p_i_c-15.201.2401-1.x86_64

              libgcc_s.so.1(GCC_3.0) is needed by fglrx64_p_i_c-15.201.2401-1.x86_64

              libgcc_s.so.1(GCC_3.3) is needed by fglrx64_p_i_c-15.201.2401-1.x86_64

              libgcc_s.so.1(GCC_4.2.0) is needed by fglrx64_p_i_c-15.201.2401-1.x86_64

              libgcc_s.so.1(GLIBC_2.0) is needed by fglrx64_p_i_c-15.201.2401-1.x86_64

              libstdc++.so.6 is needed by fglrx64_p_i_c-15.201.2401-1.x86_64

              libstdc++.so.6(CXXABI_1.3) is needed by fglrx64_p_i_c-15.201.2401-1.x86_64

              libstdc++.so.6(GLIBCXX_3.4) is needed by fglrx64_p_i_c-15.201.2401-1.x86_64

       

      But my libgcc_s is new than this:

       

      yum list installed | grep -e gcc -e libstd -e libX

      gcc.x86_64              4.4.7-16.el6    @anaconda-base-201505101627.x86_64/6.2.0

      gcc-c++.x86_64          4.4.7-16.el6    @anaconda-base-201505101627.x86_64/6.2.0

      gcc-gfortran.x86_64     4.4.7-16.el6    @anaconda-base-201505101627.x86_64/6.2.0

      libX11.x86_64           1.6.0-2.2.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libX11-common.noarch    1.6.0-2.2.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libX11-devel.x86_64     1.6.0-2.2.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXScrnSaver.x86_64    1.2.2-2.el6     @anaconda-base-201505101627.x86_64/6.2.0

      libXau.x86_64           1.0.6-4.el6     @anaconda-base-201505101627.x86_64/6.2.0

      libXau-devel.x86_64     1.0.6-4.el6     @anaconda-base-201505101627.x86_64/6.2.0

      libXaw.x86_64           1.0.11-2.el6    @anaconda-base-201505101627.x86_64/6.2.0

      libXcomposite.x86_64    0.4.3-4.el6     @anaconda-base-201505101627.x86_64/6.2.0

      libXcursor.x86_64       1.1.14-2.1.el6  @anaconda-base-201505101627.x86_64/6.2.0

      libXdamage.x86_64       1.1.3-4.el6     @anaconda-base-201505101627.x86_64/6.2.0

      libXdamage-devel.x86_64 1.1.3-4.el6     @anaconda-base-201505101627.x86_64/6.2.0

      libXdmcp.x86_64         1.1.1-3.el6     @Rocks-6.2

      libXext.x86_64          1.3.2-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXext-devel.x86_64    1.3.2-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXfixes.x86_64        5.0.1-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXfixes-devel.x86_64  5.0.1-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXfont.x86_64         1.4.5-4.el6_6   @anaconda-base-201505101627.x86_64/6.2.0

      libXft.x86_64           2.3.1-2.el6     @anaconda-base-201505101627.x86_64/6.2.0

      libXft-devel.x86_64     2.3.1-2.el6     @anaconda-base-201505101627.x86_64/6.2.0

      libXi.x86_64            1.7.2-2.2.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXinerama.x86_64      1.1.3-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXmu.x86_64           1.1.1-2.el6     @anaconda-base-201505101627.x86_64/6.2.0

      libXmu-devel.x86_64     1.1.1-2.el6     @anaconda-base-201505101627.x86_64/6.2.0

      libXp.x86_64            1.0.2-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXp-devel.x86_64      1.0.2-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXpm.x86_64           3.5.10-2.el6    @anaconda-base-201505101627.x86_64/6.2.0

      libXpm-devel.x86_64     3.5.10-2.el6    @anaconda-base-201505101627.x86_64/6.2.0

      libXrandr.x86_64        1.4.1-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXrender.x86_64       0.9.8-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXrender-devel.x86_64 0.9.8-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXres.x86_64          1.0.7-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXt.x86_64            1.1.4-6.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXt-devel.x86_64      1.1.4-6.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXtst.x86_64          1.2.2-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXv.x86_64            1.0.9-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXvMC.x86_64          1.0.8-2.1.el6   @Rocks-6.2

      libXxf86misc.x86_64     1.0.3-4.el6     @Rocks-6.2

      libXxf86vm.x86_64       1.1.3-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libXxf86vm-devel.x86_64 1.1.3-2.1.el6   @anaconda-base-201505101627.x86_64/6.2.0

      libgcc.x86_64           4.4.7-16.el6    @anaconda-base-201505101627.x86_64/6.2.0

      libstdc++.x86_64        4.4.7-16.el6    @anaconda-base-201505101627.x86_64/6.2.0

      libstdc++-devel.x86_64  4.4.7-16.el6    @anaconda-base-201505101627.x86_64/6.2.0

       

      Why is my rpm not accepting my libgcc_s and libstdc++? Also isn't there just a repo that I can point

       

      yum to to install the rpm from?