2 Replies Latest reply on May 4, 2016 8:17 AM by Hardwood

    Radeon Settings (All versions so far inc. betas) wont open. No errors, simply wont load.

    kbradrs

      I cant seem to get Radeon settings to open on this setup:

      AMD A10-7850k cpu

      AMD MSI Radeon r9 290x gpu

      24Gb RAM

      2 x 1 Terabyte WD HDD

      MSI A88X-G45 Gaming Motherboard

      600W PSU

      Windows 10 64 Bit

      Desktop

       

      Currently tried DDU and reinstalling with no result

       

      SFC /SCANNOW tried in cmd - Got an error, can send the cbs.log to whomever and however asked

       

      Windows updated except for - Definition Update for Microsoft Office 2010 (KB3114999) 32-Bit Edition - whereas i get this error - There were problems installing some updates, but we'll try again later

      Cant find any help that resolves the problem online.

       

      Not willing to restore nor anything that requires mass data loss unless there is an easy way of recovering that data is possible.

       

      I cant find many people with this result online. And those that are meeting this problem seem to fix by installing Windows 7 SP1. As far as im aware this is not applicable with windows 10.

       

      Thankyou

        • Re: Radeon Settings (All versions so far inc. betas) wont open. No errors, simply wont load.
          amdmatt

          At this point I'd normally provide some troubleshooting steps, but it looks as if you have performed most of them already.

           

          Then next thing to try would be a clean installation of Windows, so you'll need to backup your data first.

           

          Install Windows

          Fully Update Windows (this will take several restarts)

          Install our latest drivers

          Install your other software include MS Office.

           

          Following that order should resolve the issue.

          • Re: Radeon Settings (All versions so far inc. betas) wont open. No errors, simply wont load.
            Hardwood

            I don't know how much fiddling you want to do before going ahead with Matt's suggestion but..

            I have the same motherboard and cpu and win10x64 and it's working fine. Right now the difference is I don't have a discreet GPU installed. So if you're up to it, pull out the 290x and on restart go into bios setup and make sure Settings/advanced/integrated Graphics config is set to Init graphics adapter - IGD and Init graphics devices as Auto. Now if you get to desktop and radeon settings doesn't load try the DDU route once more.

            If everything is good then put the 290x back in and change from IGD to PEG  save it and restart. Don't forget to change the vid cable back to the 290x.

            If that works then try the latest driver update again.

            /cross fingers.