5 Replies Latest reply on May 4, 2016 7:25 PM by goodplay

    Problem with my R9 290 and Fallout 4

    hessejt

      First, my system information:

      • AMD Graphics Card
        • AMD R9 290X
      • Desktop
      • Operating System
        • Windows 10 64bit
      • Driver version installed
        • Radeon Software Crimson Edition 16.4.2
      • Display Devices
        • Asus VH238 1920x1080 @60Hz Active DP to HDMI adapter
      • Motherboard
        • Gigabyte B85M-DS3H
      • CPU/APU
        • i5-4460 CPU @ 3.20GHz, 4 cores
      • Power Supply Unit  Make, Model & Wattage
        • PSU EVGA 650W
      • RAM
        • 8GB

       

      So for a while my computer was running fallout 4 just fine, and I had over 75 hours of gameplay. Then, one day out of the blue my computer decided it wasn't going to load the game anymore. Anytime I boot up the game it goes to a black screen before immediately crashing to desktop. When I right-clicked on my desktop to check my settings for my R9, I couldn't find the catalyst control center, only the one for my intel integrated card. I reinstalled the control center and updated my drivers, and got fallout 4 to stop crashing to desktop. However, the video attached to this post will show you what is now happening. As you can see, the graphics card is not rendering the game properly, and controls are extremely sluggish. I have no idea what the problem is or how I go about fixing it. Please help!

        • Re: Problem with my R9 290 and Fallout 4
          goodplay

          Got a link to your steam or beth.forum post/s, so we don't have to repeat all suggested fixes ?.

            • Re: Problem with my R9 290 and Fallout 4
              hessejt

              I haven't received any responses yet from my bethesda post, and I haven't posted to steam. I have tried uninstalling and reinstalling the game, which did not help.

                • Re: Problem with my R9 290 and Fallout 4
                  goodplay

                  Is this only on FO4,running any mods.

                  Is device manager showing yellow mark against card, what driver version(is it win basic or amd vers.).

                    • Re: Problem with my R9 290 and Fallout 4
                      hessejt

                      I am not running any mods, and I don't have any other games installed on my computer that are graphically intensive enough to need a dedicated graphics card, so the other games have been running fine. The device manager says the card is working fine, and that the driver version is 16.150.2211.0, which is the latest AMD version. When I right-click on the desktop and click on "AMD Radeon Settings" however, I get the error message: "No AMD Graphics Driver is installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate for your AMD hardware". I have uninstalled my drivers manually and with AMD's own cleanup utility, and have reinstalled them both manually and with AMD's auto-detect utility, and nothing has gotten rid of the error message. Right now when I click on the auto-detect utility it says that my drivers are up to date. When I go to the device manager it shows the graphics card, says it's running fine, and says it is up to date. Yet when I go to AMD Radeon Settings, it claims that I don't have the drivers. What is going on?