AnsweredAssumed Answered

Extensions VK_KHR_surface and VK_KHR_win32_surface have disappeared

Question asked by particlepeter on Apr 29, 2016
Latest reply on Jun 2, 2016 by particlepeter

The mentioned extensions have disappears suddenly, unfortunately I am not sure why and when. I installed two things before I noticed the issue:

- Driver Crimson Edition 16.3.2

- LunarG Vulkan SDK 1.0.11.0

 

I doubt the later one is responsible, I tried all the other SDK versions without success, but who knows. Today I installed the Crimson Edition 16.4.2 Hotfix, but the problem remains.

The LunarG Vulkan Samples exit with a Missing extension error code. I confirmed within my own project that exactly the two mentioned extensions are missing. I had four extensions available on my system, VK_KHR_swapchain and VK_EXT_debug_report are still present.

 

I think the last driver which exposed all extensions was the beta driver Non-WHQL-64Bit-Radeon-Software-Crimson-16.4.2-Win10-Win8.1-Win7 from April the 20th.

Installing this driver over the current one does not solve the problem. I must admit that I am not sure if this is a driver bug at all, but what else could it be ?

 

As a side Note (some more fishiness): Even though yesterdays hotfix (16.4.2) is installed, the radeon settings window is convinced that Driver 16.3.2 (WHQL) is newer than the hotfix and suggest it to be installed. I tried that as well, didn't solve the problem either.

 

My System: APU: A10-7800, OS : Win 8.1 x64

 

Edit:

Meanwhile I installed Win 10 x64 as dual boot on the system and updated the drivers to Crimson Edition 16.4.2 Hotfix Win 10 x64. The problem does not exist on there, all four extensions are listed.

BUT (!!!) on Win 8 the implementation WAS listing 3 Queue Families, one of them a compute queue family with 4 queues.

Now, on Win 10 the implementation IS still listing 3 Families, but the compute queue exposes only 1 queue.

 

What's going on dear AMD engineers?

 

Message was edited by: Peter Particle

Outcomes