AnsweredAssumed Answered

Audio Settings Change to Stereo when AVR is turned off. - SOLVED!!!

Question asked by cybrsage on Apr 23, 2016
Latest reply on Apr 25, 2016 by amdmatt

I have a Windows 7 Professional HTPC with an A10-6700 Richland Quad-Core APU connected via HDMI to an Onkyo 3010 AVR, which is then connected via HDMI to a Panasonic PT4000AE projector.  All items are 1080p @60Hz capable, the Onkyo is 11.x capable as well.  I have a 9.2 surround system.


I set my video output to 1080p 59Hz (which then always shows as 60 in the Control Panel for some reason) and then I use the speakers icon in the system tray to configure the Playback Device (the APU HDMI Audio) to be 7.1 with the fronts set to large.  I never turn off the HTPC, but I do turn off the AVR and the Projector.  When I turn them back on, the Audio settings have reset back to stereo.


So, after many months of digging around I finally found the solution and wanted to put it here for all to see forever.  EDID is the problem and EDID Override is the solution.  The problem is that as the AVR turns off, the HTPC sees the TV as the only HDMI display and the TV is limited to Stereo sound.  It then resets itself to stereo sound and I am stuck there until I manually change it.  The solution is quite elegant and simple.


You must create a new Monitor.inf file to replace the installation file Windows is using for your monitor (be it a TV, AVR, whatever).  How it works and why is explained here:


Basically, the inf file will create a new set of registry keys called EDID Override.  These registry keys will override ALL detected EDID settings.  So how do you create the inf file so you can forever have your 7.1 channel setup (with large fronts but small surrounds)?  That is simplicity itself.  You need to download the Monitor Asset Manager utility, which is also called MonInfo.  You can download it here:


EnTech Taiwan | Utilities | Monitor Asset Manager


Before you install it, setup your audio and video to be EXACTLY what you want them to be.  Install moninfo.exe and run it and it will record your EDID info.  Use the Real Time capture and save it as an inf file (I named it Onkyo.inf since it is for an Onkyo 3010 receiver).  Opening it, I noticed it preferred 1080i instead of 1080p in the inf file, so I changed it to be 1080p and 59Hz and saved the change (it can be edited as a simple text file).


You then go into hardware manager and find your display device and load the new drivers.  You have to manually search and select them to make sure you are using the inf file you just created.  Once installed, reboot the PC.  The problem is now GONE FOREVER!!!!  I tested it by turning off the AVR but not the TV or Projector, turning off all of them but the HTPC, turning off every possible combination (including the PC) and each time I reentered Windows the HTPC was set to 7.1 surround with large fronts and small surrounds!  YAY!!!


No more handshaking problems!!!!!!!!