9 Replies Latest reply on Oct 21, 2016 1:10 PM by docious

    QT5core.dll and other QT components not installing with any installer greater than 16.1.1 causing Radeon Settings/Crimson to not load

    ebonclaw

      System Specifications:

      Windows 10 64 bit edition

      ASUS M5A99FX Pro Rev 2.0

      Sapphire R9 Fury Tri-X (non OC version)

      AMD FX-8370 (mild overclock to 4.3ghz)

      8GB RAM

      240GB PNY SSD

      750W Antec HIgh Current Gamer PSU

       

      I recently attempted to install the latest 16.4.1 hotfix drivers because I've been enjoying Ashes of the Singularity lately.  I downloaded the installer, ran DDU in safe mode, nuked the c:\AMD folder and proceeded to install after a reboot.  The drivers seem to run fine, but I noticed while playing BF4 I started getting some texture corruption and multicolors flashing strobes and various rendering issues after playing for a while.  CAM software noted that the card's temperature was reaching 83C, higher than it had ever gotten, so I figured I needed to adjust the fan profile and give the cooling a boost.  However, when I went to open Radeon Settings, I noticed it hadn't loaded.  Strange, but I'll launch it from the start menu and adjust away I figured.  When attempting to launch from start menu, I received multiple popup dialog boxes stating that the software couldn't load because QT5core.dll and other various QT components couldn't be found.  The rest of the folders and things installed there seem to be fine and normal, and I see several QT FOLDERs, but not the QT dlls I expect to see based on the 16.1.1 install.  I found that these files are installed in the C:\program files\AMD\cnext\cnext folder during software installation, so I checked there and couldn't find them at all.  So I rolled back to 16.3.1, and once again, Crimson wouldn't load for the same reason.  These files only seem to go in when I install 16.1.1.  I've run SFC and DISM Restore Image commands figuring it might be some corruption.  I even went so far as to using the 16.1.1 install, making a backup copy of these files, nuking the 16.1.1 install, installing 16.4.1, and then pasting the files to the location they should be in.  This time, when launching Crimson, I don't get error messages in dialog boxes, but the program doesn't run either.  Nothing happens when I launch it.  Not even an error in event viewer. 

      I tried using regsvr32 in cmd (run as admin) to register the copied .dlls, but cmd errors, saying that the .dll is there, but can't be loaded because the entry point can't be found. 

      I've also tried running the setup file, then after extraction, quitting, locating the c:\amd folder and running the setup file as admin from there, with the same result.

      I've also manually created the AMD folder at c:\program files\AMD where the installer points to and given full security privileges for all users, admin or not, to have full control rights over that folder, figuring that maybe the installer didn't have permission to write the QT driver files there for some reason.  Nope.  Same result.

      I thought that, however unlikely, my download might have been corrupted.  I redownloaded the installer, ran as admin, same result, no QT5 dlls.

      I've tried installing the software with ALL applications selected, and without the AMD Gaming Evolved app, with no success.

      I've repaired all Visual C++ libraries and visual studio components as I initially thought that it was a visual c++ component.

      Every installation has been preceeded by using DDU to nuke previous install.

      I'm hitting a pretty hard brick wall at this point, I would like to be running the latest drivers for a variety of reasons, or at the very least 16.3.1, but I need Crimson to run.  Any help from the experts as to why these QT files are just simply not installing with the 16.3 and 16.4 software?  I should note that when running these installers, they seem to run abnormally fast at the software installation parts; the driver installs seem to take the normal amount of time, but it seems like it's done in a split second when it hits the application install parts, whereas the 16.1.1 installer takes more time to finish (but also seems to install and register the QTcore components it needs).  My conclusion is that for some reason, the installer for these drivers is, for some reason, skipping these components and maybe others I just don't know about yet when installing.  But the 16.1.1 installer is installing everything properly.  From the research I've done, my case is pretty unique, with only one other person reporting issues with these components and Crimson, and all he had to do was manually register the files with regsvr32, mine aren't even making it in!