1 Reply Latest reply on Apr 20, 2016 8:44 PM by black_zion

    Fury Nano Screen Blanking

    benjiosaur

      I had previously owned a HD7870 graphics card. This ran fine using the Catalyst Control Centre.

       

      I upgraded to the Crimson software and this caused my screen to go immediately blank when running any intensive full screen games. (The monitor displayed "No input"). The system appeared to still be responsive; I could hear the game audio and the HDD light was flashing. The system then worked fine when I rolled back to the older Catalyst drivers.

       

      I have since purchased an Oculus Rift and a Fury Nano to replace the HD7870. I performed a full system reinstall after installing the new card. The card worked great on the older Catalyst drivers. HOWEVER. The Oculus software insists that I use the Crimson software; it won't let me use the older Catalyst drivers. So I now get the same screen blanking when running intensive full screen games. If I reduce the card's clock speed by 10% (from 1000MHz to 900MHz), the issue seems to mostly resolve itself at a cost of reduced performance. However GTA 5 under maximum settings still causes the screen blanking, as does the Unreal Engine demo for the Oculus Rift.

       

      I am using a DisplayPort to DVI cable for my monitor (Dell 2407WFP). The Oculus plugs into a HDMI port. The PSU is 900W.

       

      Do you have any idea what is causing this please? Has anyone else had a similar issue?

       

      Thanks