AnsweredAssumed Answered

Yamakasi Q270 - Switch from GTX570 to Fury X - No display on monitor, TV displays fine

Question asked by whatsdrugs on Apr 19, 2016
Latest reply on Apr 22, 2016 by whatsdrugs

I just upgraded from a GTX570 that displays to my 1440p monitor just fine, to a Fury X. Here's the deal... The fury x works perfectly in that it displays to other monitors or TVs, but not the catleap. I know the catleap works so that's not the problem. The latest drivers are installed so that's not the problem. I'm at my wit's end with this. I connected my tv via HDMI to the fury x and my catleap via display port to dvi. Windows 10 shows the TV and monitor as generic pnp in device manager. Catalyst shows both monitors but for the TV it shows detailed info and for the catleap it says "DVI disabled". The only options for the catleap are "Extend", "duplicate", and "replace" all of which do absolutely nothing. If i ask windows to chance resoluton, it only shows the TV. If I click "detect" it says no other monitors detected! How can that be when it's in device manager!? Win+P does nothing regardless of what option I select. Doing a power reset on the PC (unplug and hold power button for 60 seconds then power back on) does nothing. The cables are fine. I know this because they work with other displays. There is something messed up with the Fury X not really understanding the type of monitor the catleap is I think. I tried updating generic pnp drivers but they're up to date.

 

Side note: I have this problem every time I change the graphics card. Last time I fixed it by hooking up two monitors, changing the resolution on one monitor to 1440p, and when it went black I hotswapped the HDMI cord from that monitor to the catleap and clicked "accept resolution change". Ever since, the catleap has been working fine. Till I changed to the Fury X.

 

Please help me before I have a stroke. Hahaha.

 

-----

 

Bump! Guys, I really need help with this. Just got a DP to DUAL DVI active adapter and it doesn't work either!

 

-----

 

Alright, new development. I plugged the TV in again with the new adapter and it properly detects the Yamakasi, but it doesn't display. If I powercycle the yamakasi, it flashes the display for a split second then goes dark again. Why is this? I know the display is fine as it works great with the GTX570. This adapter (DP to Dual DVI) is meant to support up to 2560x1600 and I'm at 2560x1440P.

 

Thanks.

Outcomes