18 Replies Latest reply on Apr 20, 2016 11:16 PM by tlsxavier

    Crossfire 295x2

    tlsxavier

      Hi I am having some issues with my 295x2 while playing games/running applications I noticed that both GPU's are not operating properly. according to the two "profile overdrive's" in the  radeon settings application. the first GPU constantly peaks to 100% activity and goes up to 500MHZ GPU clock and 1250 MHZ Memory clock. howeve the second Profile Overdrive barely shows any activity occasionally going to 10% (mostly sits at 0%) and the GPU clock and Memory clock sit at 300 and 150 respectively. I am new to Crossfire and AMD cards having used Nvidia cards my entire life. I don't really understand the program that well and you tube video's have not been that helpful. is this normal and advice would be appreciated. I should note the primary game I play is The division. And I am using the "AFR Friendly" Mode.

       

      Thanks in advance.

        • Re: Crossfire 295x2
          tlsxavier

          I should also state that while playing the division I get about 40FPS with all my settings on Low and I am using windows 10. this is not what I expected from a $1000 card that is just over a year old.

          • Re: Crossfire 295x2
            tlsxavier

            Any help with this? would be greatly appreciated!

            • Re: Crossfire 295x2
              amdmatt

              Please provide more information so we can help.

               

              CrossFire must be run in exclusive fullscreen mode to function correctly, please check The Division is not running in Windowed or Borderless Windowed mode.

               

              There is currently an issue under investigation with this game at the moment which involves flickering with CrossFire enabled, so you may wish to keep it disabled for now until a updated driver is available.

                • Re: Crossfire 295x2
                  tlsxavier

                  How do I disable/enable crossfire? I went to Radeon Additional settings and their are no options under the AMD crossfire. I took a screenshotCapture.PNG

                    • Re: Crossfire 295x2
                      amdmatt

                      Add the executable of the game you want to disable CrossFire for to Radeon Settings. Select it, then under AMD CrossFire Mode set it to Disabled.

                      1 of 1 people found this helpful
                        • Re: Crossfire 295x2
                          tlsxavier

                          I did that. but it still shows the crossfire logo at top right when I run full screen mode and I am still getting that flickering.Capture.PNG

                            • Re: Crossfire 295x2
                              gemini002@hotmail.com

                              Yes this is broken even if you disable it in game profile. I have to turn off crossfire completely in order to play The Division.

                              I5-4690K

                              9 290 crossfire with R9 390

                              Win 10

                                • Re: Crossfire 295x2
                                  tlsxavier

                                  How did you turn it off completely?

                                    • Re: Crossfire 295x2
                                      gemini002@hotmail.com

                                      In crimson go to display then additional settings shut off crossfire from there.

                                        • Re: Crossfire 295x2
                                          amdmatt

                                          That option is not available for dual GPU users.

                                           

                                          It looks like a bug that you are not able to disable CrossFire using a profile. We are currently investigating a similar issue but thought it was limited to DX9 apps, apologies for any inconvenience caused. In the meantime if you play the game in Windowed mode, that should disable CrossFire.

                                           

                                          ray_m

                                          1 of 1 people found this helpful
                                            • Re: Crossfire 295x2
                                              tlsxavier

                                              Hi I just had a friend come over and take a look at everything. we managed to fix a lot of the issues like low from rates crossfire bug etc but running a very old windows 7 driver. 15.7.1 with the old CCC instead of the new radeon program. But hopefully the new driver you guys release will fix a lot of the issues.

                                              2 of 2 people found this helpful
                                                • Re: Crossfire 295x2
                                                  colesdav

                                                  Can I ask where you downloaded Amd 15.7.1 from please? I cannot find it.

                                                  I just tried amd-catalyst-omega-14.12-with-dotnet45-win8.1-64bit on my system with "The Division".

                                                  It flickers on Crossfire benchmark, the flicker doesn't look as bad as 16.4.2 but I think that is just

                                                  because the FPS performance is much lower in amd-catalyst-omega-14.12.

                                                  The Graphics do not look as good either on any given setting.

                                                  • Re: Crossfire 295x2
                                                    colesdav

                                                    It's o.k. I found 15.7.1 here.

                                                    Legacy

                                                    I will try it out on "The Division" next.

                                                    Thanks,

                                                    colesdav.

                                                      • Re: Crossfire 295x2
                                                        colesdav

                                                        Hi,

                                                         

                                                        I just tried the 15.7.1 Driver and I still see Flicker with Crossfire enabled. The performance I see is very similar to the behaviour I see in AMD Crimson Radeon Settings 16.4.2, except, again, the Visual Graphics Quality does not look as good as it does in Crimson. Also the "The Division" Benchmark results seem to be lower performance than what I was getting using the  Crimson 16.4.2 driver.

                                                         

                                                        I have a couple of questions for you.

                                                         

                                                        (1). Can I please ask did you have the following button set in your Catalyst Control Center Setting?

                                                        It is, I believe, off by default. The button is "Enable AMD CrossFireX for applications that have no associated application profile"

                                                         

                                                         

                                                         

                                                        (2). Did you make sure that you could see the AMD CrossfireX Logo in the top right hand corner of the Screen when running "The Division"?

                                                        To enable it do the following.

                                                         

                                                         

                                                        Reason I ask is since Update 1.1 of the Division, the game seems "reluctant" to launch directly into CrossFireX mode.

                                                        You can be mistaken in thinking you are running in Fullscreen mode (and therefore CrossFireX) unless you make sure you see the CrossFireX logo in the top right hand of the screen.

                                                         

                                                        In summary, I still get the best performance on "The Division" in terms of FPS and Graphics Quality by sticking with AMD Crimson Radeon Settings 16.3.2, disabling Crossfire in Radeon Additional Settings, and running/benchmarking the game in Windowed (FullScreen Mode)  versus any other older driver I have seen yet.

                                                         

                                                        I have not yet tried AMD 16.4.1 driver as I was finishing off testing on 16.3.2.

                                                         

                                                        AMD have noted the flickering issue with "The Division" in Crossfire mode.

                                                        I will wait now until I see an update regarding this from AMD.

                                                        In the meantime I see reasonable FPS results by running on a single gpu, even in Utra with MAX AA Graphics Settings and no Overclocking of CPU or GPU on single  1080p monitor.

                                                         

                                                        I can see the flickering issue is definitely there in AMD Catalyst 15.7.1 and 14.12 when running the Update 1.1 of "The Division".

                                                        I will be returning to the better performing and much better User Interface of AMD Crimson Radeon Settings 16.3.2 / updating to 16.4.1 next.

                                                         

                                                        Hope this helps in some way.

                                                        colesdav

                                                          • Re: Crossfire 295x2
                                                            tlsxavier

                                                            I think you might be using the wrong driver. I used the "windows 7 driver" even though I currently have windows 10 installed on my PC.

                                                            secondly I disabled all cross fire because the frame rate was lower then not using crossfire. However with this driver when I enabled crossfire and made it full screen I was not getting the usual flickering. But I still disabled it because the performance was worse in regards to frame rate.

                                                      • Re: Crossfire 295x2
                                                        alexbnice

                                                        I was able to disable it on my 295x2

                                                        • Re: Crossfire 295x2
                                                          gemini002@hotmail.com

                                                          oh great thank Matt

                                          • Re: Crossfire 295x2
                                            alexbnice

                                            I had to turn off crossfire on my 295x2 because it was flickering really bad while playing The Division. I'm getting 30-40 fps on Med @4k