4 Replies Latest reply on Apr 30, 2017 9:01 AM by calvinwong

    Experienced flickering and then black screens after AMD driver auto update with my r9 270x

    holderhek

      Hello, after the latest driver update, I got into some troubles... Ill describe it below.

       

      My system:

      • AMD Graphics Card
        • R9 270X
      • Operating System
        • Windows 7 64 bit
      • Driver version installed
        • Tried installing a bunch. The latest ones and almost every one of last years... last one though was amd-catalyst-14.4
      • Display Devices
        • Samsung T24C310 @60Hz
      • Motherboard
        • MSI H97M-G43
      • CPU
        • Intel  i7 4770
      • Power Supply
        • EVGA 600B, 600W
      • RAM
        • 2x corsair vengeance 1666

       

      My issue:

      • I had windows 10 installed and after the update I started experiencing flickering in normal usage, like navigating on the internet or at the desktop/folders. When I played games, like Rocket League, Dota, Counter-Strike, I had some serious flickering until complete driver failure. Sometimes it recovered on its own and then I got the message saying so (Driver stopped working but it has recovered, something like this.). I got tired of it and then uninstalled the driver and then tried to install the older one (Crimson Edition 16.3.2).

      Well, I still got the same issue, so rolled back a bit further and installed a bunch of others. Everytime time I performed a complete wipe of the display driver (registry and stuff)

      I decided to format the whole thing and install Windows 7 again, as I was frustated with other things related to windows 10. I installed the catalyst version 14.4 for windows 7 and now after I reboot my system after the installation, I get a black screen after the Starting Windows Logo. Then I have to start in safe mode and uninstall the driver so it can boot normally. Again, tried a bunch of other drivers, did a clean install of Windows three times and nothing...

       

      Got my old HD 5770 to see if it works on it and it actually did.... but it seems odd that this is a hardware issue... not sure though as my knowledge does not go much further.

       

      My r9 270x was working PERFECTLY until this last update, On Wednesday (06/04/2016) I guess, and I don't know what else to do.

       

      Any help is very appreciated.

       

      Renato