1 Reply Latest reply on Apr 7, 2016 6:13 AM by amdmatt

    Radeon R9 285 keeps crashing

    cobweb

      Hi all, and thanks in advance for any help.

       

      Yesterday the automatic updater installed new drivers (16.4.1) for my graphics card. Now every time I play Elder Scrolls Online the card crashes- freezing the game. The card normally recovers itself, but by then the game has also crashed. It has also happened during general use, so it isn't restricted to an ESO problem. In fact the Radeon setting program seems to regularly crash when opened. There were 0 issues before the software update.

       

      I have tried reinstalling. I have also tried installing 16.3.2- which I presume is the previous driver. Unfortunately I always seem to end up installing a big installer package which dumps 16.4.1 onto my machine, whatever I actually asked it to do (I started from the 16.3.2 program and unchecked all "install latest drivers" options during installation).

       

      Please help- I only have a couple of gaming days of holiday left before returning to work, and I have just lost 1 through this!

       

      If it helps I am running a quad core i5 processor on win 10 64bit