1 Reply Latest reply on Apr 17, 2016 3:44 AM by furryfur

    Crossfire 7870 lastest driver 4/4/2015 - Still black screen in most valve games.

    computerfreek

      Hey everyone,

       

      I need a fix here, this is driving me insane. I have the lastest Crimson driver (4/4/2015) and everytime I launch a game like L4D, L4D2, CSS, CSGO, anything valve related it shows a black screen. I can play BF3, and Titan Fall but can't play BF4. Black Screen. I have tried removing the drivers, reinstalling them. Now I'm a tech guy by trade and have been around the block a couple of times. I even took the time and said- hey maybe its Windows 10 and reinstalled EVERYTHING! I didn't keep a game file or a config file. Black screens are still happening. However if I remove a second monitor and then turn crossfire off and then restart - then plug in the second monitor and turn crossfire back on it is fixed for that system state. IE watch this video I made:  AMD driver released 3/28/2016 still broken - YouTube .

       

      I need a fix, I'm getting tired of dealing with driver issues every day. I was hoping this latest driver would fix it. But I guess I'm wrong... BTW: My friend has duel Fury's X's and is having this same problem to............. This is not a video card problem - this is a driver issue. Each card has been tested by it self without the one, also power supply was tested.

        • Re: Crossfire 7870 lastest driver 4/4/2015 - Still black screen in most valve games.
          furryfur

          I think you mean 4/4/"2016" otherwise those drivers would be a year old. Anyway, I think I have the exact same problem. I only have a few games to try currently but most of them won't start (just get a black screen, with a flickering mouse sometimes). Most of my games are on steam however it also happens when I try to play Starcraft II. I've been able to work around the issue for most games by running them in Windowed or Borderless Window mode which seems to fix the issue. I thought maybe it was a crossfire issue because of this, however I am still unable to launch almost any of my games in fullscreen mode even after setting crossfire mode to disabled in the game's profile. Unfortunately it isn't always easy to get the games I want to play to start in windowed mode the first time I run them. I am currently trying to play Dust: An Elysian Tail, but I just get a black screen when I try and there doesn't seem to be an easy way to set the game to startup in window mode without been able to get into the game to change the settings first.

           

          I am running Windows 10 64bit with latest drivers (16.4.1), I have 2x HD 7970 graphics cards in crossfire configuration. I also have two monitors hooked up. One through an active Displayport -> DVI adapter and the other using a DVI -> VGA adapter (the DVI port is broken on this monitor).

          1 of 1 people found this helpful