AnsweredAssumed Answered

Problems with Crimson drivers, Gigabyte R9 390 G1 Gaming

Question asked by psicotic on Apr 1, 2016
Latest reply on Dec 4, 2016 by enemymind

     Hi. I have problems with Gigabyte R9 390 G1 Gaming, and appears to be the fault of the Crimson drivers.

I explain my situation. I have assembled a whole new computer. First all went well, with the drivers I downloaded from Gigabyte page for the GPU, but when I updated the drivers to the new Crimson I have problems.

The problem is that often the computer freezes with a black screen if I'm playing (with all games), and after a few seconds the light goes out and the LED on the motherboard PCIEx slot where I've installed the GPU stays on red.

When I'm on the Windows desktop or doing anything else happens the same as I described above, but instead of a black screen, I get a blue screen saying there is an error of drivers, Windows collects information, shuts down the PC and the red LED lights.

 

     I tried to return to the Catalyst driver, and the problem goes away, but if I return to the Crimson drivers, no matter the version it is, the problem returns.

I have also tried to completely reformat the computer and install the operating system and everything from the beginning, but when I update to the Crimson drivers the problem persists.

 

I would like to install the Crimson drivers, because I bought a virtual reality HMD (HTC-VIVE), and the Catalyst drivers will not work well with this new device.        

 

NOTE: My current monitor works at 144Hz and 1080p.

 

Thank you for your attention and sorry for my english.

 

CPU: Intel I7-4790k

Motherboard: ASUS Z97-AR

RAM: G.Skill Ripjaws X DDR3 1866 PC3-14900 16GB 2x8GB CL9 (in dual channel)

GPU: Gigabyte Radeon R9 390 Gaming G1 8GB GDDR5 (installed in the firts PCIEX16 slot)

PSU: EVGA SuperNOVA 1000W G2 80Plus Gold

SSD: Samsung 850 Evo SSD Series 250GB SATA3

Monitor: Monitor 24'' AOC G2460FQ (144Hz, 1080p) coneccted by Displayport.

Operative System: Windows 10 Pro 64bits

Current GPU drivers: AMD Crimson 16.3.2 (I tried other versions, but the problem persist)

Outcomes