AnsweredAssumed Answered

AMD Raedon, Nvidia, Directx and Dragon Age 2 (Windows 8.1/10)

Question asked by sydmayl on Mar 25, 2016

Hello there.

I'm a fan of the Dragon Age games by Bioware and recently rebought all of the (3) games for PC off of Origin.

Dragon Age:Origins (2009) and Dragon Age: Inquisition (2014) both run fine on my PC, but when I go to play Dragon Age 2 (2011) I run into some issues.

 

Basically as I run the game, eventually I start to notice that the game has failed to load textures for the maps which results in objects being a gross flat white colour. Evetunally this causes whole area maps to have nearly no colour. This glitch has been known to happen with Dragon Age 2 when running a later Nvida graphics card; however it now seems to be happening with my AMD graphics card as well. I have also seen people call it a glitch with the cards and Directx 11, however I have this problem even if I set the game to use Directx 9 settings.

 

I'm very computer illiterate when it comes to software so I would very much like some help.

 

I'm not exactly sure what info I should leave to help somebody help me, but if you tell me what I need to give you info on, I'll certainly get it.

 

Thank you in advance to anyone who takes the time to help me.

 

Also, a quick google search with the key terms Dragon Age 2 and graphics glitch will usually bring up more than one hit for more info

 

Thanks

Outcomes