26 Replies Latest reply on Mar 29, 2016 10:05 AM by goodplay

    Crimson Driver not working on a 7970

    foxslink

      Hi

      So I just re formated my PC and installed all Mo/Bo's drivers , then installed crimson 15.2 and rebooted, after windows logo the screen goes black and i cant do anything, then i have to do windows repair to restore before i installed this driver, What could be doing wrong? IS there a specific version i have to use? id appreciate your help.

        • Re: Crimson Driver not working on a 7970
          kingfish

          Yes there are specific drivers for different cards and OS. Will be happy to try and assist you once you have furnished the requested information.

          INFORMATION REQUIRED WHEN POSTING A QUESTION

            • Re: Crimson Driver not working on a 7970
              foxslink
              • AMD Graphics Card
                • Sapphire Hd 7970 Dual-x 3gb Gddr5
              • Operating System
                • Windows 7 64bit
              • Driver version installed
                • Radeon Software Crimson Edition 15.12
              • Display Devices
                • Dell U2414h, HDMI to mini HDMI, 1080p / 60 hz;
              • Motherboard
                • GIGABYTE GA-Z77X-UD5H LGA1155
              • CPU/APU
                • Intel Ivy bridge i5 3570k
              • Power Supply Unit  Make, Model & Wattage
                • Corsair TX650M 650w 80Plus Bronze
              • RAM
                • Kingston Predator 8GB

                  After installing this Crimson driver  and rebooting the pc, the screen goes black after the windows logo. All of this after re formatting windows and installing all the Motherboard drivers. I hope  you can help me now.
                  Looking forward to your reply
                • Re: Crimson Driver not working on a 7970
                  kingfish

                  A red flag comes up in my mind when I see "All of this after re formatting windows". The biggest problem, is people do not update their computer before trying to install graphics drivers. You should manually go to WU..set the option "Windows and other Microsoft products" and look for updates. SP1 must be installed. Especially important are the 'optional' updates. These include .netframework and C++ upgrades. After you have installed all available, reboot and return to WU and run it again..and again....until there are no more. Then install the graphics drivers for your computer > Desktop

                  Clean Install AMD Graphics Drivers

                    • Re: Crimson Driver not working on a 7970
                      foxslink

                      Ok im sure i had all updates when i installed the driver, specially SP1, but maybe i didnt update the optional ones. I will try again doing the  steps of the guide you linked, i couldnt login to normal mode so i did a driver uninstall using DDU,  should i install the Crimson Edition 16.3.1 Hotfix  or the 15.2?
                      thanks for your help

                      • Re: Crimson Driver not working on a 7970
                        foxslink

                        I just installed the crimson 16.3.1 hotfix driver after doing all the steps you mentioned and I still have the same issue :S, the black screen of death. What could probably cause this? Im starting to think the problem might be  the VGA , cuz other hardware is just fine. what do you think?

                          • Re: Crimson Driver not working on a 7970
                            kingfish

                            Check for system file corruption. Open a command prompt as administrator and enter     sfc /scannow   . Let it run and repair any corrupted files, if it can. It won't take long. Then run check disk > Check your hard disk for errors

                            This is the option you want " To check for both file errors and physical errors, select both Automatically fix file system errors and Scan for and attempt recovery of bad sectors."

                              • Re: Crimson Driver not working on a 7970
                                foxslink

                                ok i did both and no issues found on eitheir,  the chckdsk took a while though, but no bad sectors, i think if i install the driver now the black screen will probably happen again, what is the right move now?

                                  • Re: Crimson Driver not working on a 7970
                                    kingfish

                                    Man I'm stumped.

                                    All of the steps you've taken should have revealed the problem. Maybe someone else has a suggestion?

                                      • Re: Crimson Driver not working on a 7970
                                        foxslink

                                        I will try to update the BIOS to version F14 and then try running the driver again, im now reading the Mo/bo's manual to learn how to do this, wish me luck

                                        http://download.gigabyte.us/FileList/Manual/mb_manual_ga-z77x-ud5h_e.pdf

                                          • Re: Crimson Driver not working on a 7970
                                            bearcat22

                                            Does your monitor go into sleep mode shortly after it black screens. Like does the front LED on the monitor start blinking?

                                            Are you able to boot into Safemode?

                                             

                                            Intel 3930k, Asus Rampage iv Formula, Enermax 1250 EVO Galaxy, Corsair CML16GX3M4X1600C8 Low Profile 4 x 4GB, 150 gig VelociRaptor(32meg), Crucial M500 240GB SSD, 750 gig wd Caviar, 2x Sapphire HD 7970, LG Blu-ray burner,Corsair 600T case, Swiftech H220x Cooler, Bios 1305, Win7 Pro 64bit, Samsung S27A850DS Monitor 2560x1440

                                              • Re: Crimson Driver not working on a 7970
                                                foxslink

                                                nope,  it doesnt go into sleep mode, it just stays black indefinitely, nor it doesnt blink,
                                                Im able to boot into safe mode all the time after failing to boot any AMD driver in normal startup, ive tried plenty of AMD drivers and none of them has worked so far, except one that was from my VGA's CD , but when i was in the desktop after installing and rebooting, it suddenly crashed and the black screen appeared again. Thats as far as ive gotten to solve this issue :S. Any ideas?

                                                  • Re: Crimson Driver not working on a 7970
                                                    bearcat22

                                                    Wow, tough one. I would rum Memtest from a bootable cd or usb stick just to rule out RAM. But I don't think it's a hardware problem since everything was working before the reformat. It almost sounds like there's a screwup when the bios is handing over to the o\s. Reset the mainboard bios. There should be instuctions in the manual that came with it. You'll havta pull the battery off the mainboard. Then disconnect all extra drives, usb devices etc. Then try booting into Windows. Were you using Crimson or Catalyst drivers before you reformatted?

                                                      • Re: Crimson Driver not working on a 7970
                                                        foxslink

                                                        sup,  ive been doing more trial and error and i think the problem might even be the graphics card or as you said a hardware problem, so  i sent a support ticket to both Sapphire and Gigabyte respectively to see if they can help , if not then ill have to ask for RMA, i hope they reply soon. Still,  im not  sure which one is at fault, the GPU or the Motherboard . Its strange cuz how can I have my Monitor plugged into the VGA and have it working if the card is "dead" , that means its not completely dead, otherwise it would not show anything just like after when i install the drivers, on top of that the card's fans are working too.
                                                        Before all of this happened I was using the Catalyst Driver, and old version. I did reset the Bios by removing the battery when the PC was off and unplugged, but I did not remove the extra drive i had, which was just one. I also updated the bios to version f14 using the QFlash method as goodplay mentioned, it worked smoothly,  but what if i reset the bios again, would i lose the update i did? Lastly I think puttin some thermal paste on the GPU would help too, since i hvent done that for more than a year, whcich i think is bad,which paste would you recommend? i dont think using the CPUs paste is good choice. Thanks for thy help folks

                                                        Looking forward to your reply

                                                          • Re: Crimson Driver not working on a 7970
                                                            bearcat22

                                                            You won't lose your bios update if you reset it. Did you have a second hard drive plugged in when you install Windows? Normally this isn't a problem, but I've seen Windows install screwup and put the boot partition on the wrong drive. Again, disconnect all drives and USB devices that aren't needed to install Windows.

                                                            Go into the bios and disable your onboard graphics card if it has one. Make sure your monitor is plugged into your graphics card.

                                                            Reinstall Windows doing a Clean Install.

                                                            Once it's done install the Chipset Drivers. Reboot

                                                            Install Audio Drivers. Reboot

                                                            Install Ethernet driver. Reboot

                                                            Install Windows Update. Reboot

                                                            Go Back to Windows Update and see if additional ones have shown up. Install and  reboot.

                                                            Download and install the newest NetFramework and reboot.

                                                            Ok, now the graphics driver.

                                                            Install the last working Catalyst driver and CCC you used before you did the original reformat.

                                                            If everything is still ok then DON'T update to Crimson drivers.

                                                             

                                                            PS

                                                            Just thought of something. You do know not to install drivers from Windows Update unless you have a specific reason to do so, right?

                                                              • Re: Crimson Driver not working on a 7970
                                                                goodplay

                                                                Actually, three's no need to disable onboard graphics on this mobo.

                                                                I've left mine at default(Init.display first/onboard on auto).Comes in handy for troubleshooting.

                                                                OP should try boot with monitor to onboard.

                                                                If OP does have 2nd harddrive, he could also try the boot override in bios(to see if boot partition is there).

                                                                He probably should also check all cables/connections again.

                                                                • Re: Crimson Driver not working on a 7970
                                                                  foxslink

                                                                  In another forum someone told me something similar about dissabling the onboard graphics card, this is what he told me . Try booting up into safe mode after crimson installed and disabling the intel HD graphic card from device management. That solved my problem. But sometimes intel HD graphic will be re-enabled after system upgrade and the system will hang up again. It worked perfectly, and your recommendation was very similar to that, but now i would like to know how to disable the intel graphics permanently, how can do this? thanks to everyone for your help , I learnt a lot about technical repairs these last 4 days, gotta look on the bright side , right?

                                                          • Re: Crimson Driver not working on a 7970
                                                            goodplay

                                                            @bearcat22

                                                            Like that you posted sys.specs.

                                                            It's a shame we can't make them fixed(or implemented) in posts like old forum.

                                          • Re: Crimson Driver not working on a 7970
                                            goodplay

                                            I'm curious as to why/where/how you installed mobo drivers.

                                            When you restart from restore, what graphics driver is being used(check in device manager).

                                            Take note of your boot options in the restored state, then check again in new setup.

                                            Also possible mobo drivers have altered graphics start up in bios(longshot).