0 Replies Latest reply on Mar 17, 2016 9:06 AM by chummel87

    Installing new Radeon R7 370 on Lenovo Desktop with AMD A10-7800 APU

    chummel87

      I recently purchased a Radeon R7 370 to install onto my Lenovo H50 series desktop (90BG0002US) Amazon.com: Lenovo H50 Desktop (90BG0002US): Computers & Accessories

      The APU is a A10-7800 APU with, from my understanding, integrated R7 Radeon Graphics (Kaveri architecture) as a part of the APU.

       

      I have Windows 10.

       

      I purchased a Corsair 500w power supply to power the card, and I was able to fit the card onto the motherboard and fans start spinning on startup so it appears to be powered on. (the only thing I haven't done is connect the card directly to my monitor because I need a VGA-HDMI adapter cable or something similar for my old monitor).

       

      I run into problems when installing the drivers for the card. So I need some guidance installing the card and having the computer use it as opposed to the integrated R7 graphics.

       

      My first attempt: I used the CD and ran express driver install. After analysis, installation got underway, but after a few instances of the screen going black, coming back on, and installation progress proceeding, my computer screen froze. After a few minutes, a BSOD appeared (if i recall correctly... Thread Stuck in Device Driver).

       

      Second attempt: I first disabled the R7 graphics in the device manager. Then I ran the CD express driver install. After analysis, installation of the driver completed, and installation of AMD Catalyst Control started (as part of the ongoing overall installation process), when the green bar for this part of the install filled, all progress stopped and my computer just hanged at that part of the installation. (but did not freeze up). Eventually I got a BSOD (critical structural failure - or something similar)

       

      Third attempt. I disabled the R7 graphics in the device manager. I ran CD custom install and opted out of installing AMD Catalyst Control (since it's already installed for the integrated graphics I thought it might not be necessary). Installation of the driver completed successfully. I checked the device manager and R7 370 graphics was present and not disabled (although it had been recognized and enabled according to the device manager this entire time, so this was not different). I ran a game (Grey Goo) to test whether the card was working, but the game's video control options would not recognize the card. (I tested this a few times actually, with integrated graphics enabled, it only found the R7 graphics, with integrated graphics disabled, it only found Windows Basic Renderer). I then used the device manager to upgrade drivers on the r7 370, which completed successfully, however, this had no effect on what I was seeing in video options. I then tried to open AMD Catalyst Control (I currently have Crimson 15.1...don't recall exact version but can update). This would not open when the integrated R7 graphics was disabled, stating that no AMD drivers were present (which confused me since I was under the impression that the r7 370's drivers had installed successfully. When I enabled the integrated R7 graphics, I was able to open the AMD Catalyst Control and review the graphics processors. AMD CCC recognized both the R7 integrated and R7 370, but listed the R7 integrated as (Primary) and the R7 370 as (Disabled), and I could find no way in the CCC to change those settings. I then tried to go into the system BIOS to switch the video display setup. My two options in this BIOS were AUTO and PEG. AUTO was listed as VGA with onboard graphics (or something like that), so i switched it to PEG, thinking this referred to the PCI slot I put my graphics card in. I then restarted, and attempted to run a game to see if it was working, but the game did not recognize the R7 370, and I was only able to open the CCC with the R7 integrated enabled, which continued to show it as the primary and the R7 370 as disabled.

       

      Anyhow, that's where I'm at currently, so if anyone has any advice or instructions, I would be happy to hear it!

       

       

       

      Lenovo desktop specifications:

       

      Processor 3.5 GHz AMD A10 7800 (3.9 turbo)

      RAM 8GB DDR3

      Hard Drive 1 TB

      Graphics Coprocessor AMD Integrated ATI Radeon R7

      Wireless Type 802.11bgn

      Number of USB 2.0 Ports 4

      Number of USB 3.0 Ports 2Brand Name Lenovo

      Item model number 90BG0002US

      Hardware Platform PC

      Operating System Windows 8.1 *(I upgraded to Windows 10)*

      Item Weight 15.6 pounds

      Item Dimensions L x W x H16.14 x 6.30 x 13.98 inches

      Processor Brand AMD

      Processor Count 1

      Hard Drive Rotational Speed 7200 RPM

      Optical Drive Type DVD RW

       

      Message was edited by: Matt B Duplicate thread. We have responded to your initial thread.