0 Replies Latest reply on Mar 14, 2016 10:08 PM by nuggetpiece

    290x possibly fried? Out of Warranty, Sapphire no help, any experts lurking?

    nuggetpiece

      Hey guys,

       

      Sapphire reference 290x

      Back in January I swapped my 290x into my new 6700K system. After the AMD drivers installed I found to my dismay that I had the dreaded "black screen". I had to put this problem down for a month or two because of work obligations, but I guess I'm ready to jump into some desperation fixes?

       

      Here is what I had done back in January:

      - Reseated card

      - Moved card from one 6700k system to a different 2500k system.

      - Tested with windows 7, windows 8.1, and windows 10.

      - Tested with (2) different power supply units. Corsair AX750 and AX760

      - Tested with different pci-e power cables. Including seperate wires.

      - Tried installing catalyst drivers all the way back into the 14.xxx, 15.xxx and crimson drivers up to 16.1

      - Tried updating bios to newer bios. Used latest sapphire 290x reference bios from gpu-z site.

      - Tried modified bios from 390x for 290x reference boards.

      - Tried reapplying thermal paste

      - Tried Sapphire support, Warranty ended back in October, so they told me I was out of luck.

       

      Here is my new discovery, it looks like I have a broken/fried SMD on the back of the card... PINKY for scale.

      I seem to still get 2.376 ohms on that resistor, same resistors nearby get similar reads 2.376, 2.378, 2.373.

       

      Any expert ideas?