AnsweredAssumed Answered

How can I fix graphics fragmentation in games with the HD 5970 on Windows 10 Pro x64?

Question asked by tsukasadt on Mar 13, 2016
Latest reply on Mar 19, 2016 by tsukasadt

System Build

OSWindows 10 Pro x64
GPUAMD Radeon HD 5970
GPU Control PanelCatalyst 2015.0804.21.41908 (Catalyst 15.7.1)
GPU Driver15.20.1062.1004-150803a1-187674C
Display Devices2x SHARP LC-32SB28UT (https://www.sharpusa.com/ForHome/HomeEntertainment/LCDTV/Archives/LC32SB28UT.aspx)
MotherboardASUS P6X58D Premium (https://www.asus.com/Motherboards/P6X58D_Premium/)
CPUIntel BX80613I7980X (http://ark.intel.com/products/47932/Intel-Core-i7-980X-Processor-Extreme-Edition-12M-Cache-3_33-GHz-6_40-GTs-Intel-QPI)
Power SupplyCORSAIR HX850 (http://www.corsair.com/en-us/hx-series-hx850-power-supply-850-watt-80-plus-gold-certified-modular-psu)
RAMCorsair HX3X12G1600C9 G (http://www.corsair.com/en-us/hx3x12g1600c9)

Issue Description

As the title says, I receive what I can best describe as a fragmentation of graphics when I access games. Here's a screenshot of the issue as it occurs in Final Fantasy XIV:

ffxiv_01052016_161118.png

When I'd upgraded to Windows 10, I was too busy to be able to play a lot of games, but when I started to be able to play again, I started encountering this issue. As can be seen in the screenshot, the user interface is completely unaffected. This is mirrored in Star Wars: The Old Republic, StarCraft II, and just about any other game I try. I decided to try my luck with non-MMORPGs but found the issue persisted on those, also.

Here's a list of what I've tried:

  1. Ensuring the drivers were up-to-date.
  2. Uninstalled drivers and Catalyst, restarted machine, confirmed generic drivers had auto-installed, and reinstalled drivers and Catalyst.
  3. Modified game settings for multiple games until I finally gave up on being able to fix it with the game settings.
  4. Attempted using Crimson Edition.
  5. Reinstalled games.
  6. Reseated GPU in the motherboard.
  7. Changed slot in motherboard.
  8. Reinstalled OS.
  9. Attempted overclock.
  10. Removed overclock modification.

Nothing had any affect on the issue in any games I tried. I was shocked to find it in the original Halo with and without compatibility mode!

I have absolutely no issue outside of "fullscale" games. Browser games, videos, graphic-heavy websites, etc. have no issue with displaying. For "fullscale" game, short of replacing my GPU, which I can't afford to do, I'm out of ideas on what else I can try to fix this.

Outcomes