19 Replies Latest reply on Aug 22, 2016 5:37 AM by thielek

    SAPPHIRE NITRO R9 380X 4G LOW FPS HELP

    thielek

      Hey guys,

       

      So I've just built a new computer and bought this 380X to hold me over with 1080p gaming until the next-gen of cards come out, but I've been getting some weird results.

       

      I bought the card with World of Warcraft in mind as I saw some benchmarks showing really good 1080P performance on ultra settings, but I'm getting nowhere near what I've read. Using the gaming evolved suggested settings I'm getting like 25-30FPS in my garrison alone. I was pretty shocked. I tried the Warcraft suggested settings just to see what it thought I should use and it says I should only be playing on 'good'. I'm using the latest Crimson drivers 16.3. I've tried using a few different versions of drivers but haven't noticed any real differences. Any suggestions?

       

      I'm using it on Windows 10 with an i7-5820k and 16GB DDR4 RAM so it can't be my CPU. I've tested it and it's performing properly. I did run Firestrike and the score seemed low compared to other 380X. Anyone have any thoughts on what the problem could be? Or is this just how the card is supposed to perform in Warcraft?

       

      Thanks for the feedback.