0 Replies Latest reply on Mar 10, 2016 10:10 AM by dsmith304

    Catalyst not allowing native display resolution

    dsmith304

      So I recently built a new desktop for gaming. I did a clean install of windows 7 ultimate. My process was to install that, then the drivers from the motherboard disc (which seemed to include everything), then I tried to update windows as much as possible before installing Radeon drivers. No antivirus software was installed. After installing the Radeon driver, my display resolution was changed to 1080i 30hz from the native 1080p 60hz, and Catalyst will not let me select the native resolution or create it as a custom resolution. It tells me the display will not support it. Though it would allow me to enable 720p 60hz and 1080p 24hz (which was worse). I have tried to reinstall windows and drivers and had the same result. It causes some screen tearing and fuzzy text mostly. The card seems to play games perfectly fine other than it not always allowing me to select the correct resolutions. Worth noting that some games are unaffected while others will either not allow me to select 1080 or go fullscreen or some such. I've also tried reseating the card and such. haven't tried using display port or DVI instead of HDMI yet, as I do not have either on hand.

       

      My rig:

      i5 6400 @3.2ghz

      Gigabyte Z170 HD3P

      Radeon R9 390 (Powercolor CPS+)

      Skilljaws 8gb DDR4